aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-curl
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2019-06-26 15:08:11 -0300
committerEneas Queiroz <cotequeiroz@gmail.com>2019-07-02 16:53:47 -0300
commit3e78945eaf243fe07bd513302972ae49006cfed1 (patch)
tree7ec7afee8843e8043f1e9c7223d75ec89e67dbad /lang/python/python-curl
parentaa8685e025a0d2cd0864246e656abfd857f09031 (diff)
python-curl: fix compilation with libcurl-wolfssl
This allows compilation when libcurl is build with wolfssl as its SSL backend. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'lang/python/python-curl')
-rw-r--r--lang/python/python-curl/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/lang/python/python-curl/Makefile b/lang/python/python-curl/Makefile
index a7b2b92ae..862507e63 100644
--- a/lang/python/python-curl/Makefile
+++ b/lang/python/python-curl/Makefile
@@ -55,19 +55,22 @@ $(call Package/python-curl/description)
(Variant for Python3)
endef
+PYTHON_PKG_SETUP_ARGS:=
+PYTHON3_PKG_SETUP_ARGS:=
+
ifdef CONFIG_LIBCURL_OPENSSL
- PYTHON_PKG_SETUP_ARGS:=--with-openssl
- PYTHON3_PKG_SETUP_ARGS:=--with-openssl
+ PYTHON_PKG_SETUP_ARGS+=--with-openssl
+ PYTHON3_PKG_SETUP_ARGS+=--with-openssl
endif
ifdef CONFIG_LIBCURL_GNUTLS
- PYTHON_PKG_SETUP_ARGS:=--with-gnutls
- PYTHON3_PKG_SETUP_ARGS:=--with-gnutls
+ PYTHON_PKG_SETUP_ARGS+=--with-gnutls
+ PYTHON3_PKG_SETUP_ARGS+=--with-gnutls
endif
ifdef CONFIG_LIBCURL_MBEDTLS
- PYTHON_PKG_SETUP_ARGS:=--with-mbedtls
- PYTHON3_PKG_SETUP_ARGS:=--with-mbedtls
+ PYTHON_PKG_SETUP_ARGS+=--with-mbedtls
+ PYTHON3_PKG_SETUP_ARGS+=--with-mbedtls
endif
$(eval $(call PyPackage,python-curl))