aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-curl
diff options
context:
space:
mode:
authorWaldemar Konik <informatyk74@interia.pl>2017-06-13 15:33:10 +0200
committerWaldemar Konik <informatyk74@interia.pl>2017-08-18 08:16:10 +0200
commit253bcd2ce1fe51516a33e791c649ff078f1ecb10 (patch)
treee2ab8591d647ca6fd6621a00d6d4d0dd1b2292a2 /lang/python/python-curl
parent5455a88d45397bf9bdb4c87d087e93ab57709619 (diff)
python-curl: add new package
Signed-off-by: Waldemar Konik <informatyk74@interia.pl>
Diffstat (limited to 'lang/python/python-curl')
-rw-r--r--lang/python/python-curl/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/lang/python/python-curl/Makefile b/lang/python/python-curl/Makefile
new file mode 100644
index 000000000..cc29f8ec5
--- /dev/null
+++ b/lang/python/python-curl/Makefile
@@ -0,0 +1,47 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pycurl
+PKG_VERSION:=7.43.0
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Waldemar Konik <informatyk74@interia.pl>
+PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE_FILE=COPYING-LGPL
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://dl.bintray.com/pycurl/pycurl/
+PKG_HASH:=aa975c19b79b6aa6c0518c0cc2ae33528900478f0b500531dbcdbf05beec584c
+
+PKG_BUILD_DEPENDS:=python libcurl
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/python-curl
+ CATEGORY:=Languages
+ SECTION:=lang
+ SUBMENU:=Python
+ TITLE:=Python module interface to the cURL library
+ URL:=http://pycurl.io/
+ DEPENDS:=+python +libcurl
+endef
+
+define Package/python-curl/description
+Python module interface to the cURL library.
+endef
+
+define Build/Compile
+ $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+endef
+
+define Package/python-curl/install
+ $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+ $(CP) \
+ $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+ $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,python-curl))