aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-curl
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/python-curl
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-curl')
-rw-r--r--lang/python/python-curl/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/lang/python/python-curl/Makefile b/lang/python/python-curl/Makefile
index 8248c9bd7..e285967fe 100644
--- a/lang/python/python-curl/Makefile
+++ b/lang/python/python-curl/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pycurl
PKG_VERSION:=7.43.0.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=ec7dd291545842295b7b56c12c90ffad2976cc7070c98d7b1517b7b6cd5994b3
@@ -19,25 +19,17 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python-curl/Default
+define Package/python3-curl
CATEGORY:=Languages
SECTION:=lang
SUBMENU:=Python
TITLE:=Python module interface to the cURL library
URL:=http://pycurl.io/
- DEPENDS:=+libcurl
-endef
-
-define Package/python3-curl
-$(call Package/python-curl/Default)
- DEPENDS+=+PACKAGE_python3-curl:python3
- VARIANT:=python3
+ DEPENDS:=+libcurl +python3
endef
define Package/python3-curl/description
PycURL is a Python interface to libcurl, the multiprotocol file transfer library.
-.
-(Variant for Python3)
endef
PYTHON3_PKG_SETUP_ARGS:=