aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-curl
diff options
context:
space:
mode:
authorVal Kulkov <val.kulkov@gmail.com>2019-05-14 01:47:09 -0400
committerVal Kulkov <val.kulkov@gmail.com>2019-05-14 01:47:09 -0400
commit0dd445a248c629b37923ae88999abd2fb19ec1a5 (patch)
tree143b617a1c0a259cec4268d20ac33ed3832c6251 /lang/python/python-curl
parent1f4df64f6a90510de13449e5dc0bd3f73e9f02d3 (diff)
python-curl: remove hardcoded dependency on mbedtls
Fixes issue #8978. If libcurl's SSL library is set to an SSL library other than libmbedtls, compilation fails. This patch configures python-curl to use the currently selected SSL library for libcurl. Signed-off-by: Val Kulkov <val.kulkov@gmail.com>
Diffstat (limited to 'lang/python/python-curl')
-rw-r--r--lang/python/python-curl/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/lang/python/python-curl/Makefile b/lang/python/python-curl/Makefile
index a5b4f54d4..ec364aa88 100644
--- a/lang/python/python-curl/Makefile
+++ b/lang/python/python-curl/Makefile
@@ -55,8 +55,20 @@ $(call Package/python-curl/description)
(Variant for Python3)
endef
-PYTHON_PKG_SETUP_ARGS:=--with-mbedtls
-PYTHON3_PKG_SETUP_ARGS:=--with-mbedtls
+ifdef CONFIG_LIBCURL_OPENSSL
+ PYTHON_PKG_SETUP_ARGS:=--with-openssl
+ PYTHON3_PKG_SETUP_ARGS:=--with-openssl
+endif
+
+ifdef CONFIG_LIBCURL_GNUTLS
+ PYTHON_PKG_SETUP_ARGS:=--with-gnutls
+ PYTHON3_PKG_SETUP_ARGS:=--with-gnutls
+endif
+
+ifdef CONFIG_LIBCURL_MBEDTLS
+ PYTHON_PKG_SETUP_ARGS:=--with-mbedtls
+ PYTHON3_PKG_SETUP_ARGS:=--with-mbedtls
+endif
$(eval $(call PyPackage,python-curl))
$(eval $(call BuildPackage,python-curl))