aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-curl
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-01-07 23:21:07 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-01-09 16:36:02 +0100
commit00fce347a5b054f1d38baaac735a357aad3d0a24 (patch)
tree149661b9b88567dfc7e034cf2dca49446d81dbb1 /lang/python/python-curl
parentbb089121b38ba0161d7ca524d5220b10e5f3ee69 (diff)
treewide: fix incorrect *_BUILD_DEPENDS
Build depends refer to source package names, not binary package names. In many cases, PKG_BUILD_DEPENDS simply duplicated runtime dependencies of a source package's binary packages; as the corresponding source packages are implicitly added as bulid dependencies, PKG_BUILD_DEPENDS can simply be dropped in these cases. In the other cases, *_BUILD_DEPENDS is fixed to refer to the correct source package name. Dependency of mysql-server is adjusted from libncursesw to libncurses (as libncursesw is a virtual package provided by libncurses), so the build dependency on ncurses is emitted unconditionally. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'lang/python/python-curl')
-rw-r--r--lang/python/python-curl/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/lang/python/python-curl/Makefile b/lang/python/python-curl/Makefile
index 679ffef3c..f325560a4 100644
--- a/lang/python/python-curl/Makefile
+++ b/lang/python/python-curl/Makefile
@@ -15,8 +15,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://dl.bintray.com/pycurl/pycurl/
PKG_HASH:=43231bf2bafde923a6d9bb79e2407342a5f3382c1ef0a3b2e491c6a4e50b91aa
-PKG_BUILD_DEPENDS:=python libcurl
-
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)