aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-crcmod
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-01 22:11:07 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-02 14:57:30 +0800
commitc37b15e1c49cf27de8f34f43e93a7a5c184be9e0 (patch)
treea009f48d54bf7599950fbf6619004d9ef413d90e /lang/python/python-crcmod
parent3732cab3dfe711f9a445b1abff61178fd7c5519e (diff)
python-libraries: Remove Python 2-only packages
These are either libraries that backport Python 3 features for Python 2 programs, or libraries that have not had Python 3 variants added to them by anyone. These packages will be added to the abandoned packages feed. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-crcmod')
-rw-r--r--lang/python/python-crcmod/Makefile49
1 files changed, 0 insertions, 49 deletions
diff --git a/lang/python/python-crcmod/Makefile b/lang/python/python-crcmod/Makefile
deleted file mode 100644
index 818fa72ea..000000000
--- a/lang/python/python-crcmod/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-crcmod
-PKG_VERSION:=1.7
-PKG_RELEASE:=1
-PKG_MAINTAINER:=Micke Prag <micke.prag@telldus.se>
-PKG_LICENSE:=MIT
-
-PYPI_NAME:=crcmod
-PKG_HASH:=dc7051a0db5f2bd48665a990d3ec1cc305a466a77358ca4492826f41f283601e
-
-PKG_BUILD_DEPENDS:=python
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python-package.mk
-
-define Package/python-crcmod
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=python-crcmod
- URL:=http://crcmod.sourceforge.net/
- DEPENDS:=+python-light
-endef
-
-define Package/python-crcmod/description
- The software in this package is a Python module for generating objects that compute the Cyclic Redundancy Check (CRC). There is no attempt in this package to explain how the CRC works. There are a number of resources on the web that give a good explanation of the algorithms. Just do a Google search for "crc calculation" and browse till you find what you need. Another resource can be found in chapter 20 of the book "Numerical Recipes in C" by Press et. al.
-endef
-
-define Build/Compile
- $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
-endef
-
-define Package/python-crcmod/install
- $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
- $(CP) \
- $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
- $(1)$(PYTHON_PKG_DIR)
-endef
-
-$(eval $(call BuildPackage,python-crcmod))