aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-click-log
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-05-29 19:15:29 +0800
committerRosen Penev <rosenp@gmail.com>2023-05-29 18:16:56 +0300
commit67a854aee28f6a360af1c595fdea396c9193b6e9 (patch)
tree491dc9f18b8a3ec7f965aab3f1cffcda333e5947 /lang/python/python-click-log
parentf45f067f3f9726acfb0d5edd193731bc587ff54f (diff)
click-log: Update to 0.4.0, rename source package
This renames the source package from click-log to python-click-log to match other Python packages. This also updates the package to download from PyPI, and updates the package title, URL, and dependencies. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-click-log')
-rw-r--r--lang/python/python-click-log/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/python/python-click-log/Makefile b/lang/python/python-click-log/Makefile
new file mode 100644
index 000000000..01f6c0e82
--- /dev/null
+++ b/lang/python/python-click-log/Makefile
@@ -0,0 +1,36 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-click-log
+PKG_VERSION:=0.4.0
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+PYPI_NAME:=click-log
+PKG_HASH:=3970f8570ac54491237bcdb3d8ab5e3eef6c057df29f8c3d1151a51a9c23b975
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-click-log
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ URL:=https://github.com/click-contrib/click-log
+ TITLE:=Logging integration for Click
+ DEPENDS:=+python3-light +python3-logging +python3-click
+endef
+
+define Package/python3-click-log/description
+ Simple and beautiful logging for click applications
+endef
+
+$(eval $(call Py3Package,python3-click-log))
+$(eval $(call BuildPackage,python3-click-log))
+$(eval $(call BuildPackage,python3-click-log-src))