aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-charset-normalizer
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-07-20 15:39:57 +0800
committerRosen Penev <rosenp@gmail.com>2023-07-24 22:46:12 -0700
commit5ef294f64f36cf44b63e585364dccf61c444febe (patch)
tree3ffc22992c3cad9acb690de1cb6c91d1738f4628 /lang/python/python-charset-normalizer
parentc5c02c060bd9480bb47cd5f9631f72d099c4cbe8 (diff)
python-charset-normalizer: Add new package
From the README: A library that helps you read text from an unknown charset encoding. Motivated by chardet, I'm trying to resolve the issue by taking a new approach. All IANA character set names for which the Python core library provides codecs are supported. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-charset-normalizer')
-rw-r--r--lang/python/python-charset-normalizer/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/lang/python/python-charset-normalizer/Makefile b/lang/python/python-charset-normalizer/Makefile
new file mode 100644
index 000000000..7a2e4ee07
--- /dev/null
+++ b/lang/python/python-charset-normalizer/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-charset-normalizer
+PKG_VERSION:=3.2.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=charset-normalizer
+PKG_HASH:=3bb3d25a8e6c0aedd251753a79ae98a093c7e7b471faa3aa9a93a81431987ace
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-charset-normalizer
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Real First Universal Charset Detector
+ URL:=https://github.com/Ousret/charset_normalizer
+ DEPENDS:=+python3-light +python3-codecs +python3-logging
+endef
+
+define Package/python3-charset-normalizer/description
+A library that helps you read text from an unknown charset encoding.
+Motivated by chardet, I'm trying to resolve the issue by taking a new
+approach. All IANA character set names for which the Python core library
+provides codecs are supported.
+endef
+
+$(eval $(call Py3Package,python3-charset-normalizer))
+$(eval $(call BuildPackage,python3-charset-normalizer))
+$(eval $(call BuildPackage,python3-charset-normalizer-src))