aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-chardet
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-01 22:21:16 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-02 14:57:30 +0800
commit658b1b67587c4698f6a4c182e9afea7cb5fba2ee (patch)
tree94f402f8080841dc3a6c7f4a701d7aeb21a6f6b2 /lang/python/python-chardet
parentc37b15e1c49cf27de8f34f43e93a7a5c184be9e0 (diff)
python-libraries: Remove Python 2 variants
The Python 2 variants will be added to the abandoned packages feed. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-chardet')
-rw-r--r--lang/python/python-chardet/Makefile18
1 files changed, 1 insertions, 17 deletions
diff --git a/lang/python/python-chardet/Makefile b/lang/python/python-chardet/Makefile
index 8f2da9e42..956491cb7 100644
--- a/lang/python/python-chardet/Makefile
+++ b/lang/python/python-chardet/Makefile
@@ -17,7 +17,6 @@ PKG_HASH:=84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
-include ../python-package.mk
include ../python3-package.mk
define Package/python-chardet/Default
@@ -28,13 +27,6 @@ define Package/python-chardet/Default
URL:=https://github.com/chardet/chardet
endef
-define Package/python-chardet
-$(call Package/python-chardet/Default)
- TITLE:=Universal encoding detector for Python 2
- DEPENDS:=+PACKAGE_python-chardet:python
- VARIANT:=python
-endef
-
define Package/python3-chardet
$(call Package/python-chardet/Default)
TITLE:=Universal encoding detector for Python3
@@ -42,12 +34,8 @@ $(call Package/python-chardet/Default)
VARIANT:=python3
endef
-define Package/python-chardet/description
- Universal encoding detector for Python 2 and 3
-endef
-
define Package/python3-chardet/description
-$(call Package/python-chardet/description)
+ Universal encoding detector for Python 2 and 3
.
(Variant for Python3)
endef
@@ -60,10 +48,6 @@ define Py3Package/python3-chardet/install
done
endef
-$(eval $(call PyPackage,python-chardet))
-$(eval $(call BuildPackage,python-chardet))
-$(eval $(call BuildPackage,python-chardet-src))
-
$(eval $(call Py3Package,python3-chardet))
$(eval $(call BuildPackage,python3-chardet))
$(eval $(call BuildPackage,python3-chardet-src))