aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-chardet
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-05-22 03:57:55 +0800
committerJeffery To <jeffery.to@gmail.com>2020-05-22 03:57:55 +0800
commit3c36696a5652da83ad0de42d86edb271bf4db728 (patch)
tree65040600555b83f805675a077d3259549e775a88 /lang/python/python-chardet
parent643b91abb3defc28fafff35c363dd04a9658fac4 (diff)
python-packages: Add usr/bin symlinks without "3" suffix
Previously, binaries installed by Python packages will have a non-suffixed Python 2 version and a suffixed Python 3 version, e.g. pip and pip3. With the removal of Python 2, the non-suffixed names are no longer taken. This adds symlinks for the non-suffixed names linking to the suffixed scripts (or in the case of pip, easy_install, and python-config, to the fully-versioned scripts). Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-chardet')
-rw-r--r--lang/python/python-chardet/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python/python-chardet/Makefile b/lang/python/python-chardet/Makefile
index f9c0cf0b1..1b71631ef 100644
--- a/lang/python/python-chardet/Makefile
+++ b/lang/python/python-chardet/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-chardet
PKG_VERSION:=3.0.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=LGPL-2.1
PYPI_NAME:=chardet
@@ -38,6 +38,7 @@ define Py3Package/python3-chardet/install
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
for bin in $(1)/usr/bin/*; do \
mv $$$$bin $$$${bin}3 ; \
+ $(LN) $$$${bin##*/}3 $$$$bin ; \
done
endef