aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-chardet
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/python-chardet
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-chardet')
-rw-r--r--lang/python/python-chardet/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/lang/python/python-chardet/Makefile b/lang/python/python-chardet/Makefile
index 956491cb7..f9c0cf0b1 100644
--- a/lang/python/python-chardet/Makefile
+++ b/lang/python/python-chardet/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-chardet
PKG_VERSION:=3.0.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=LGPL-2.1
PYPI_NAME:=chardet
@@ -19,25 +19,18 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python-chardet/Default
+define Package/python3-chardet
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
URL:=https://github.com/chardet/chardet
-endef
-
-define Package/python3-chardet
-$(call Package/python-chardet/Default)
- TITLE:=Universal encoding detector for Python3
- DEPENDS:=+PACKAGE_python3-chardet:python3-light
- VARIANT:=python3
+ TITLE:=Universal encoding detector
+ DEPENDS:=+python3-light
endef
define Package/python3-chardet/description
Universal encoding detector for Python 2 and 3
-.
-(Variant for Python3)
endef
define Py3Package/python3-chardet/install