aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-boto3
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2019-04-25 22:40:39 +0200
committerDaniel Danzberger <daniel@dd-wrt.com>2019-05-06 17:30:09 +0200
commit128fa745e97c58573ccd29f07aa8db40c5391ce4 (patch)
treeb0f8a2367575f6a1a835da779106b9095115175e /lang/python/python-boto3
parentcba459f52220857189bae31929a88989aa61783e (diff)
python-boto3: Add new package
Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
Diffstat (limited to 'lang/python/python-boto3')
-rw-r--r--lang/python/python-boto3/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/lang/python/python-boto3/Makefile b/lang/python/python-boto3/Makefile
new file mode 100644
index 000000000..160cf40f2
--- /dev/null
+++ b/lang/python/python-boto3/Makefile
@@ -0,0 +1,39 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=boto3
+PKG_VERSION:=1.9.135
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/b/boto3
+PKG_HASH:=5e5805992e873e5687b5ef3b4c56c386ccb4df1c3364f8b8601d289e2f275be1
+PKG_BUILD_DIR:=$(BUILD_DIR)/boto3-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Daniel Danzberger <daniel@dd-wrt.com>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-boto3
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=AWS SDK for Python (Boto3)
+ URL:=https://aws.amazon.com/sdk-for-python/
+ DEPENDS:=+python3 \
+ +python3-jmespath \
+ +python3-botocore \
+ +python3-s3transfer
+ VARIANT:=python3
+endef
+
+define Package/python3-boto3/description
+Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK) for Python,
+which allows Python developers to write software that makes use of services like Amazon S3 and Amazon EC2.
+endef
+
+$(eval $(call Py3Package,python3-boto3))
+$(eval $(call BuildPackage,python3-boto3))
+$(eval $(call BuildPackage,python3-boto3-src))