aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-ble2mqtt
diff options
context:
space:
mode:
authorQuintin Hill <stuff@quintin.me.uk>2023-03-10 22:51:17 +0000
committerQuintin Hill <stuff@quintin.me.uk>2023-03-22 09:00:30 +0000
commit2af786a48dc3e60481f4d37dfa86400ddc28fca7 (patch)
tree5543f79d64dc0eb93f4e87a54b885b211d118bbc /lang/python/python-ble2mqtt
parent661f14c46ed43a3855f9fa4f94cd63cd031c1662 (diff)
python-ble2mqtt: add package
This package allows interfacing between BLE sensors and MQTT. Signed-off-by: Quintin Hill <stuff@quintin.me.uk>
Diffstat (limited to 'lang/python/python-ble2mqtt')
-rw-r--r--lang/python/python-ble2mqtt/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/python/python-ble2mqtt/Makefile b/lang/python/python-ble2mqtt/Makefile
new file mode 100644
index 000000000..9fff9beba
--- /dev/null
+++ b/lang/python/python-ble2mqtt/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2023
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-ble2mqtt
+PKG_VERSION:=0.1.5
+PKG_RELEASE:=1
+
+PYPI_NAME:=ble2mqtt
+PKG_HASH:=0015cae0c36badb48cbd4a1c8b1a8029e45ab0891a95363fe00624c2629b4510
+
+PKG_MAINTAINER:=Quintin Hill <stuff@quintin.me.uk>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-ble2mqtt
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Bluetooth to MQTT bridge
+ URL:=https://github.com/devbis/ble2mqtt/
+ DEPENDS:=+python3-light +python3-aio-mqtt-mod +python3-asyncio +python3-bleak +python3-logging
+endef
+
+define Package/python3-ble2mqtt/description
+ Bluetooth to MQTT bridge, add your bluetooth-capable (including controllable)
+ devices to your smart home
+endef
+
+$(eval $(call Py3Package,python3-ble2mqtt))
+$(eval $(call BuildPackage,python3-ble2mqtt))
+$(eval $(call BuildPackage,python3-ble2mqtt-src))