aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-bcrypt
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-05-29 16:49:23 +0800
committerRosen Penev <rosenp@gmail.com>2023-05-29 18:14:14 +0300
commit3def783d3c72effdb87b1168315e51295cebc20f (patch)
tree39aa9b7133e2cc67add68e51d578f219737810d6 /lang/python/python-bcrypt
parentdda8ba0ca732d613238db973f00e20dc83d8fc77 (diff)
bcrypt: Update to 3.2.2, rename source package
This is the last released version before bcrypt's Rust rewrite; this package can be further updated after the OpenWrt Rust toolchain has stablized. This also renames the source package from bcrypt to python-bcrypt to match other Python packages, and updates the list of dependencies. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-bcrypt')
-rw-r--r--lang/python/python-bcrypt/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/lang/python/python-bcrypt/Makefile b/lang/python/python-bcrypt/Makefile
new file mode 100644
index 000000000..b3855a473
--- /dev/null
+++ b/lang/python/python-bcrypt/Makefile
@@ -0,0 +1,39 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-bcrypt
+PKG_VERSION:=3.2.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=bcrypt
+PKG_HASH:=433c410c2177057705da2a9f2cd01dd157493b2a7ac14c8593a16b3dab6b6bfb
+
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=libffi/host python-cffi/host # cffi>=1.1
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-bcrypt
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Modern password hashing
+ URL:=https://github.com/pyca/bcrypt/
+ DEPENDS:=+python3-light +python3-cffi
+endef
+
+define Package/python3-bcrypt/description
+ Good password hashing for your software and your servers.
+endef
+
+$(eval $(call Py3Package,python3-bcrypt))
+$(eval $(call BuildPackage,python3-bcrypt))
+$(eval $(call BuildPackage,python3-bcrypt-src))