aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-awscli
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-20 13:53:39 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-20 16:18:06 -0300
commit65009e8127414fe6796f8ace6d532750b622773a (patch)
tree10bc0c904b6fa36663fc10b522955fbc09e85c31 /lang/python/python-awscli
parent36d0c59e99ca1d71232156a677bf1b6fe3aea736 (diff)
treewide: Add PACKAGE_* conds to python packages
If a package builds python & python3 variants, then the respective PACKAGE-python* conditional DEPENDS were added, since circular dependencies should all be resolved now. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'lang/python/python-awscli')
-rw-r--r--lang/python/python-awscli/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/lang/python/python-awscli/Makefile b/lang/python/python-awscli/Makefile
index d52faac56..c290c6ac4 100644
--- a/lang/python/python-awscli/Makefile
+++ b/lang/python/python-awscli/Makefile
@@ -28,27 +28,27 @@ endef
define Package/python-awscli
$(call Package/python-awscli/Default)
- DEPENDS:=+python \
- +python-yaml \
- +python-pyasn1 \
- +python-botocore \
- +python-rsa \
- +python-colorama \
- +python-docutils \
- +python-s3transfer
+ DEPENDS:=+PACKAGE_python-awscli:python \
+ +PACKAGE_python-awscli:python-yaml \
+ +PACKAGE_python-awscli:python-pyasn1 \
+ +PACKAGE_python-awscli:python-botocore \
+ +PACKAGE_python-awscli:python-rsa \
+ +PACKAGE_python-awscli:python-colorama \
+ +PACKAGE_python-awscli:python-docutils \
+ +PACKAGE_python-awscli:python-s3transfer
VARIANT:=python
endef
define Package/python3-awscli
$(call Package/python-awscli/Default)
- DEPENDS:=+python3 \
- +python3-yaml \
- +python3-pyasn1 \
- +python3-botocore \
- +python3-rsa \
- +python3-colorama \
- +python3-docutils \
- +python3-s3transfer
+ DEPENDS:=+PACKAGE_python3-awscli:python3 \
+ +PACKAGE_python3-awscli:python3-yaml \
+ +PACKAGE_python3-awscli:python3-pyasn1 \
+ +PACKAGE_python3-awscli:python3-botocore \
+ +PACKAGE_python3-awscli:python3-rsa \
+ +PACKAGE_python3-awscli:python3-colorama \
+ +PACKAGE_python3-awscli:python3-docutils \
+ +PACKAGE_python3-awscli:python3-s3transfer
VARIANT:=python3
endef