aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-augeas/patches
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
committerIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
commit5d8d4fbbcb5c5de9370711c19bb3510210989a98 (patch)
treed0754921833f413b7eb93fb6bb1b1c8a22fb0498 /lang/python/python-augeas/patches
parentd651082447b4392399a40ea1ae11d0bce4bfe83a (diff)
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset: find -L package/feeds/packages/ -name patches | \ sed 's/patches$/refresh/' | sort | xargs make Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Diffstat (limited to 'lang/python/python-augeas/patches')
-rw-r--r--lang/python/python-augeas/patches/001-backport-ffi-fix.patch12
1 files changed, 3 insertions, 9 deletions
diff --git a/lang/python/python-augeas/patches/001-backport-ffi-fix.patch b/lang/python/python-augeas/patches/001-backport-ffi-fix.patch
index 1ed618f2f..4009469fb 100644
--- a/lang/python/python-augeas/patches/001-backport-ffi-fix.patch
+++ b/lang/python/python-augeas/patches/001-backport-ffi-fix.patch
@@ -24,11 +24,9 @@ Closes https://github.com/hercules-team/python-augeas/issues/48.
setup.py | 1 +
3 files changed, 24 insertions(+), 6 deletions(-)
-diff --git a/augeas/__init__.py b/augeas/__init__.py
-index 0fc0d96..4af0200 100644
--- a/augeas/__init__.py
+++ b/augeas/__init__.py
-@@ -32,7 +32,7 @@
+@@ -32,7 +32,7 @@ format and the transformation into a tre
from sys import version_info as _pyver
@@ -37,8 +35,6 @@ index 0fc0d96..4af0200 100644
__author__ = "Nathaniel McCallum <nathaniel@natemccallum.com>"
__credits__ = """Jeff Schroeder <jeffschroeder@computer.org>
-diff --git a/augeas/ffi.py b/augeas/ffi.py
-index fdd8d1c..98b3175 100644
--- a/augeas/ffi.py
+++ b/augeas/ffi.py
@@ -1,9 +1,28 @@
@@ -73,7 +69,7 @@ index fdd8d1c..98b3175 100644
ffi.cdef("""
typedef struct augeas augeas;
-@@ -59,7 +78,5 @@
+@@ -44,7 +63,5 @@ const char *aug_error_details(augeas *au
void free(void *);
""")
@@ -81,11 +77,9 @@ index fdd8d1c..98b3175 100644
-
if __name__ == "__main__":
ffi.compile(verbose=True)
-diff --git a/setup.py b/setup.py
-index 65026c1..6c4265e 100755
--- a/setup.py
+++ b/setup.py
-@@ -22,6 +22,7 @@
+@@ -22,6 +22,7 @@ setup(name=name,
setup_requires=["cffi>=1.0.0"],
cffi_modules=["augeas/ffi.py:ffi"],
install_requires=["cffi>=1.0.0"],