aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-attrs
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/python-attrs
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-attrs')
-rw-r--r--lang/python/python-attrs/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/lang/python/python-attrs/Makefile b/lang/python/python-attrs/Makefile
index 82fc5d4bd..240ec6be6 100644
--- a/lang/python/python-attrs/Makefile
+++ b/lang/python/python-attrs/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-attrs
PKG_VERSION:=19.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=attrs
PKG_HASH:=f7b7ce16570fe9965acd6d30101a28f62fb4a7f9e926b3bbc9b61f8b04247e72
@@ -22,26 +22,19 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python-attrs/Default
+define Package/python3-attrs
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=Classes Without Boilerplate
URL:=https://www.attrs.org/
-endef
-
-define Package/python3-attrs
-$(call Package/python-attrs/Default)
- DEPENDS:=+PACKAGE_python3-attrs:python3-light
- VARIANT:=python3
+ DEPENDS:=+python3-light
endef
define Package/python3-attrs/description
attrs is an MIT-licensed Python package with class decorators that ease
the chores of implementing the most common attribute-related object
protocols.
-.
-(Variant for Python3)
endef
$(eval $(call Py3Package,python3-attrs))