aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-astral
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/python-astral
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-astral')
-rw-r--r--lang/python/python-astral/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/lang/python/python-astral/Makefile b/lang/python/python-astral/Makefile
index 35825e8aa..b5fe47d4f 100644
--- a/lang/python/python-astral/Makefile
+++ b/lang/python/python-astral/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-astral
PKG_VERSION:=1.10.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=astral
PKG_HASH:=d2a67243c4503131c856cafb1b1276de52a86e5b8a1d507b7e08bee51cb67bf1
@@ -22,26 +22,19 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python-astral/Default
+define Package/python3-astral
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=Calculations for the position of the sun and moon
URL:=https://github.com/sffjunkie/astral
-endef
-
-define Package/python3-astral
-$(call Package/python-astral/Default)
DEPENDS+= \
- +PACKAGE_python3-astral:python3-light \
- +PACKAGE_python3-astral:python3-pytz
- VARIANT:=python3
+ +python3-light \
+ +python3-pytz
endef
define Package/python3-astral/description
Astral is a python module for calculating the times of various aspects of the sun and moon.
-.
-(Variant for Python3)
endef
$(eval $(call Py3Package,python3-astral))