aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-apipkg/Makefile
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2020-08-03 15:29:15 +0200
committerJan Pavlinec <jan.pavlinec@nic.cz>2020-08-06 10:07:57 +0200
commit274fcf4d6c680f26aaaeb20400f80257d41608e4 (patch)
tree4acfce3eadcfebc802bd3f0fa3b14422ff719a3e /lang/python/python-apipkg/Makefile
parentd17b29cbdf1c351b3c456e402c2045631bca63a0 (diff)
python-apipkg: add new package
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'lang/python/python-apipkg/Makefile')
-rw-r--r--lang/python/python-apipkg/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/lang/python/python-apipkg/Makefile b/lang/python/python-apipkg/Makefile
new file mode 100644
index 000000000..37aa0c171
--- /dev/null
+++ b/lang/python/python-apipkg/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-apipkg
+PKG_VERSION:=1.5
+PKG_RELEASE:=1
+
+PYPI_NAME:=apipkg
+PKG_HASH:=37228cda29411948b422fae072f57e31d3396d2ee1c9783775980ee9c9990af6
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_PARALLEL:=0
+HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=setuptools-scm
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-apipkg
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:= Controler for exported namespace of a Python package a
+ URL:=https://github.com/pytest-dev/apipkg
+ DEPENDS:= +python3-light
+endef
+
+define Package/python3-apipkg/description
+ apipkg is used to control the exported namespace of a Python package and greatly reduce
+ the number of imports for users.
+endef
+
+$(eval $(call Py3Package,python3-apipkg))
+$(eval $(call BuildPackage,python3-apipkg))
+$(eval $(call BuildPackage,python3-apipkg-src))