aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-aiohttp
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-07-20 15:43:37 +0800
committerRosen Penev <rosenp@gmail.com>2023-07-24 22:46:12 -0700
commit2c1b66c8867ee3a5351abad2ab5d522ca76f26db (patch)
treee2e0a0f9877c1a92ccadcf153285b17b7881db8f /lang/python/python-aiohttp
parent0eabbb8ef7ac08293e5035a8812ea4c6d33d8ec9 (diff)
python-aiohttp: Update 3.8.5, update dependencies
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-aiohttp')
-rw-r--r--lang/python/python-aiohttp/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/lang/python/python-aiohttp/Makefile b/lang/python/python-aiohttp/Makefile
index 007f41b20..e5246d2b4 100644
--- a/lang/python/python-aiohttp/Makefile
+++ b/lang/python/python-aiohttp/Makefile
@@ -7,16 +7,16 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=aiohttp
-PKG_VERSION:=3.7.4.post0
+PKG_NAME:=python-aiohttp
+PKG_VERSION:=3.8.5
PKG_RELEASE:=1
-PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=493d3299ebe5f5a7c66b9819eacdcfbbaaf1a8e84911ddffcdc48888497afecf
+PYPI_NAME:=aiohttp
+PKG_HASH:=b9552ec52cc147dbf1944ac7ac98af7602e51ea2dcd076ed194ca3c0d1c7d0bc
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=Apache-2.0
-PKG_LICENSE_FILES:=LICENSE
+PKG_LICENSE_FILES:=LICENSE.txt
PKG_CPE_ID:=cpe:/a:aio-libs_project:aiohttp
include ../pypi.mk
@@ -30,17 +30,14 @@ define Package/python3-aiohttp
TITLE:=Async http client/server framework (asyncio)
URL:=https://github.com/aio-libs/aiohttp
DEPENDS:= \
- +python3-light \
+ +python3 \
+ +python3-aiosignal \
+ +python3-async-timeout \
+python3-attrs \
- +python3-chardet \
+ +python3-charset-normalizer \
+ +python3-frozenlist \
+python3-multidict \
- +python3-async-timeout \
- +python3-yarl \
- +python3-logging \
- +python3-codecs \
- +python3-cgi \
- +python3-openssl \
- +python3-typing-extensions
+ +python3-yarl
endef
define Package/python3-aiohttp/description