aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-aiohttp-cors
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-04-20 21:52:37 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2019-07-05 21:25:13 +0200
commiteb38ddfa13a2213878e5fd51885832b708dd00a9 (patch)
tree30b02d5bdd0eee00b54cf504d1a08e5bf505d169 /lang/python/python-aiohttp-cors
parentfbc16be02f029b3b4e2d668b2ae7cd2786e190fb (diff)
python-aiohttp-cors: add package
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'lang/python/python-aiohttp-cors')
-rw-r--r--lang/python/python-aiohttp-cors/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/lang/python/python-aiohttp-cors/Makefile b/lang/python/python-aiohttp-cors/Makefile
new file mode 100644
index 000000000..4f6e641ab
--- /dev/null
+++ b/lang/python/python-aiohttp-cors/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aiohttp-cors
+PKG_VERSION:=0.7.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=aiohttp-cors-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/a/aiohttp_cors/
+PKG_HASH:=4d39c6d7100fd9764ed1caf8cebf0eb01bf5e3f24e2e073fda6234bc48b19f5d
+
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-aiohttp-cors
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=CORS support for aiohttp
+ URL:=https://github.com/aio-libs/aiohttp-cors
+ DEPENDS:= \
+ +python3-aiohttp \
+ +python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-aiohttp-cors/description
+ Implements Cross Origin Resource Sharing (CORS) support for aiohttp asyncio-powered asynchronous HTTP server.
+endef
+
+$(eval $(call Py3Package,python3-aiohttp-cors))
+$(eval $(call BuildPackage,python3-aiohttp-cors))
+$(eval $(call BuildPackage,python3-aiohttp-cors-src))