aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-aio-mqtt-mod
diff options
context:
space:
mode:
authorQuintin Hill <stuff@quintin.me.uk>2023-03-10 22:48:06 +0000
committerQuintin Hill <stuff@quintin.me.uk>2023-03-17 23:38:22 +0000
commit76b0a3c1ec7300fefbbf205cf7b97a8b04115bbf (patch)
treecb4a3f07ff59af2d585ae4187bd45844cfdea16a /lang/python/python-aio-mqtt-mod
parent1f571c011c9930ce53217606956f851a3c8de928 (diff)
python-aio-mqtt-mod: add package
This package is a dependency of ble2mqtt. Signed-off-by: Quintin Hill <stuff@quintin.me.uk>
Diffstat (limited to 'lang/python/python-aio-mqtt-mod')
-rw-r--r--lang/python/python-aio-mqtt-mod/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/lang/python/python-aio-mqtt-mod/Makefile b/lang/python/python-aio-mqtt-mod/Makefile
new file mode 100644
index 000000000..b5afab5cc
--- /dev/null
+++ b/lang/python/python-aio-mqtt-mod/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2023
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-aio-mqtt-mod
+PKG_VERSION:=0.3.3
+PKG_RELEASE:=1
+
+PYPI_NAME:=aio-mqtt-mod
+PKG_HASH:=2271f8a2fd6c6aea914896dc3d4dd6e384cd0da405b06dcfa566bd01f968bf9d
+
+PKG_MAINTAINER:=Quintin Hill <stuff@quintin.me.uk>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-aio-mqtt-mod
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Asynchronous MQTT client
+ URL:=https://github.com/devbis/aio-mqtt
+ DEPENDS:=+python3-light +python3-asyncio +python3-openssl
+endef
+
+define Package/python3-aio-mqtt-mod/description
+ Asynchronous MQTT client for 3.1.1 protocol version (mod).
+endef
+
+$(eval $(call Py3Package,python3-aio-mqtt-mod))
+$(eval $(call BuildPackage,python3-aio-mqtt-mod))
+$(eval $(call BuildPackage,python3-aio-mqtt-mod-src))