aboutsummaryrefslogtreecommitdiff
path: root/lang/python/numpy/Makefile
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2022-10-30 19:31:26 +0200
committerAlexandru Ardelean <alex@shruggie.ro>2023-05-26 11:16:17 +0300
commit8f176e30f3dae121e374be4ca7f641cc157ea152 (patch)
tree94ee297e03a66b1ff9be8f7d0d854504c0f852f5 /lang/python/numpy/Makefile
parentde130fadb5967b2dac3d45bd61e39ab6c35a797d (diff)
numpy: bump version to 1.24.3
Need to also fix build for GCC 13 + musl. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python/numpy/Makefile')
-rw-r--r--lang/python/numpy/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/lang/python/numpy/Makefile b/lang/python/numpy/Makefile
index d7e485d79..bb5b898d1 100644
--- a/lang/python/numpy/Makefile
+++ b/lang/python/numpy/Makefile
@@ -6,11 +6,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=numpy
-PKG_VERSION:=1.23.3
-PKG_RELEASE:=5
+PKG_VERSION:=1.24.3
+PKG_RELEASE:=1
PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=51bf49c0cd1d52be0a240aa66f3458afc4b95d8993d2d04f0d91fa60c10af6cd
+PKG_HASH:=ab344f1bf21f140adab8e47fdbc7c35a477dc01408791f8ba00d018dd0bc5155
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
@@ -54,6 +54,12 @@ config NUMPY_OPENBLAS_SUPPORT
endmenu
endef
+ifeq ($(ARCH),x86_64)
+# FIXME: temporary fix for x86_64 with GCC 13 + musl;
+# numpy does not detect this compiler extension, so we just enable it
+TARGET_CFLAGS += -mavx512f
+endif
+
define Build/Prepare/numpy-sitecfg
echo "[DEFAULT]" > $(PKG_BUILD_DIR)/site.cfg
echo "library_dirs = $(STAGING_DIR)/usr/lib" >> $(PKG_BUILD_DIR)/site.cfg