aboutsummaryrefslogtreecommitdiff
path: root/lang/python/flup/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-01 22:21:16 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-02 14:57:30 +0800
commit658b1b67587c4698f6a4c182e9afea7cb5fba2ee (patch)
tree94f402f8080841dc3a6c7f4a701d7aeb21a6f6b2 /lang/python/flup/Makefile
parentc37b15e1c49cf27de8f34f43e93a7a5c184be9e0 (diff)
python-libraries: Remove Python 2 variants
The Python 2 variants will be added to the abandoned packages feed. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/flup/Makefile')
-rw-r--r--lang/python/flup/Makefile19
1 files changed, 1 insertions, 18 deletions
diff --git a/lang/python/flup/Makefile b/lang/python/flup/Makefile
index 504b082a3..819346896 100644
--- a/lang/python/flup/Makefile
+++ b/lang/python/flup/Makefile
@@ -20,7 +20,6 @@ PKG_LICENSE_FILES:=PKG-INFO
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
-include ../python-package.mk
include ../python3-package.mk
define Package/flup/Default
@@ -31,14 +30,6 @@ define Package/flup/Default
URL:=https://www.saddi.com/software/flup/
endef
-define Package/python-flup
-$(call Package/flup/Default)
- DEPENDS+= \
- +PACKAGE_python-flup:python-light \
- +PACKAGE_python-flup:python-logging
- VARIANT:=python
-endef
-
define Package/python3-flup
$(call Package/flup/Default)
DEPENDS+= \
@@ -47,20 +38,12 @@ $(call Package/flup/Default)
VARIANT:=python3
endef
-define Package/python-flup/description
- Random assortment of WSGI servers.
-endef
-
define Package/python3-flup/description
-$(call Package/python-flup/description)
+ Random assortment of WSGI servers.
.
(Variant for Python3)
endef
-$(eval $(call PyPackage,python-flup))
-$(eval $(call BuildPackage,python-flup))
-$(eval $(call BuildPackage,python-flup-src))
-
$(eval $(call Py3Package,python3-flup))
$(eval $(call BuildPackage,python3-flup))
$(eval $(call BuildPackage,python3-flup-src))