aboutsummaryrefslogtreecommitdiff
path: root/lang/python/flup/Makefile
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2020-07-08 12:54:15 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2020-07-15 15:41:37 +0200
commit4aa6bf042458237aac0d249dae53d2f29e7dc703 (patch)
treee4f1a241a1f5a1b4a562df50f66af37f0b970869 /lang/python/flup/Makefile
parentf48625cbf960a76851af811c5a70b3dacccd1aea (diff)
Revert "lang: python: flup: drop package"
This reverts commit 33525fa8d5dd0b878329971fb78c6a623207dba7. Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [add me as co-maintainer, bump PKG_RELEASE, Makefile polishing]
Diffstat (limited to 'lang/python/flup/Makefile')
-rw-r--r--lang/python/flup/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/python/flup/Makefile b/lang/python/flup/Makefile
new file mode 100644
index 000000000..a0b2051b8
--- /dev/null
+++ b/lang/python/flup/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2007-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=flup
+PKG_VERSION:=1.0.3
+PKG_RELEASE:=4
+
+PYPI_NAME:=flup
+PKG_HASH:=5eb09f26eb0751f8380d8ac43d1dfb20e1d42eca0fa45ea9289fa532a79cd159
+
+PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Josef Schlehofer <pepe.schlehofer@gmail.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=PKG-INFO
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-flup
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Random assortment of WSGI servers
+ URL:=https://www.saddi.com/software/flup/
+ DEPENDS:=+python3-light +python3-logging
+endef
+
+define Package/python3-flup/description
+ Random assortment of WSGI servers.
+endef
+
+$(eval $(call Py3Package,python3-flup))
+$(eval $(call BuildPackage,python3-flup))
+$(eval $(call BuildPackage,python3-flup-src))