aboutsummaryrefslogtreecommitdiff
path: root/lang/php8/Makefile
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2023-06-12 18:52:29 +0200
committerMichael Heimpold <mhei@heimpold.de>2023-06-12 18:52:39 +0200
commit5779ae4c5deb2cf3e6e4e4461fbaa4125159a470 (patch)
tree17d0d8115768da96ac276d0eada92dd778111e41 /lang/php8/Makefile
parent9365622f27284e1541ef24a1f4a52d32a439e24b (diff)
Revert "php8: fix linking on riscv64 platform"
This reverts commit a2e76e49787e97253c02d72d27e3d304d68ff488. Now that the issue is fixed on gcc side (see openwrt/openwrt@7b4a966), we can revert this workaround here. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php8/Makefile')
-rw-r--r--lang/php8/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/lang/php8/Makefile b/lang/php8/Makefile
index 1a32d9aa1..fbe33886c 100644
--- a/lang/php8/Makefile
+++ b/lang/php8/Makefile
@@ -94,7 +94,7 @@ endef
define Package/php8-cli
$(call Package/php8/Default)
- DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp +riscv64:libatomic
+ DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp
TITLE+= (CLI)
endef
@@ -105,7 +105,7 @@ endef
define Package/php8-cgi
$(call Package/php8/Default)
- DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp +riscv64:libatomic
+ DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp
TITLE+= (CGI & FastCGI)
endef
@@ -127,7 +127,7 @@ endef
define Package/php8-fpm
$(call Package/php8/Default)
- DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp +riscv64:libatomic
+ DEPENDS+= +PACKAGE_php8-mod-intl:libstdcpp
TITLE+= (FPM)
endef
@@ -159,7 +159,6 @@ define Package/apache-mod-php8
CATEGORY:=Network
DEPENDS+=PACKAGE_apache-mod-php8:apache \
+PACKAGE_php8-mod-intl:libstdcpp \
- +riscv64:libatomic \
+libpcre2 +zlib
TITLE:=PHP8 module for Apache Web Server
endef
@@ -198,9 +197,6 @@ endif
ifeq ($(CONFIG_USE_MUSL),y)
TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
endif
-ifneq ($(findstring riscv64,$(CONFIG_ARCH)),)
-TARGET_LDFLAGS += -latomic
-endif
ifneq ($(SDK)$(CONFIG_PACKAGE_php8-mod-bcmath),)
CONFIGURE_ARGS+= --enable-bcmath=shared
@@ -607,8 +603,6 @@ define BuildModule
define Package/php8-mod-$(1)
$(call Package/php8/Default)
- DEPENDS+=+riscv64:libatomic
-
ifneq ($(3),)
DEPENDS+=$(3)
endif