aboutsummaryrefslogtreecommitdiff
path: root/lang/php8/Makefile
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2021-09-26 22:05:15 +0200
committerMichael Heimpold <mhei@heimpold.de>2021-09-26 22:05:15 +0200
commit1bff138517bd4ea93b59873590f7dfd0c7fe1931 (patch)
treedb84c105877385535615a5738b841788547bddc6 /lang/php8/Makefile
parent863acbd4ac2370eb59ea5d151f4e36e5006e286b (diff)
php8: fix module loading with glibc (refs #16642)
Without -ldl linker flag .so extensions are not loaded when glibc is used. Fix it by providing adjusted LDFLAGS for this case. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php8/Makefile')
-rw-r--r--lang/php8/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/php8/Makefile b/lang/php8/Makefile
index c6f22acc8..5d6f67008 100644
--- a/lang/php8/Makefile
+++ b/lang/php8/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=8.0.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
PKG_LICENSE:=PHP-3.01
@@ -175,6 +175,10 @@ CONFIGURE_ARGS+= \
--with-external-pcre \
--with-zlib="$(STAGING_DIR)/usr"
+ifeq ($(CONFIG_LIBC_USE_GLIBC),y)
+TARGET_LDFLAGS += -ldl
+endif
+
ifneq ($(SDK)$(CONFIG_PACKAGE_php8-mod-bcmath),)
CONFIGURE_ARGS+= --enable-bcmath=shared
else