aboutsummaryrefslogtreecommitdiff
path: root/lang/php8-pecl-krb5
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2021-12-09 08:11:10 +0100
committerMichael Heimpold <mhei@heimpold.de>2021-12-09 21:57:44 +0100
commit40cf7112b5e257bef3fdf8714876b601568ee2b4 (patch)
treeb6d6531686b4056d969dadac11323d006468a474 /lang/php8-pecl-krb5
parent31655db71127fe070af01d8f0d1eecaa661b4d80 (diff)
php7-pecl-krb5: migrate package to php8-pecl-krb5
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php8-pecl-krb5')
-rw-r--r--lang/php8-pecl-krb5/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/lang/php8-pecl-krb5/Makefile b/lang/php8-pecl-krb5/Makefile
new file mode 100644
index 000000000..a3318571a
--- /dev/null
+++ b/lang/php8-pecl-krb5/Makefile
@@ -0,0 +1,37 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PECL_NAME:=krb5
+PECL_LONGNAME:=Bindings for the Kerberos library
+
+PKG_VERSION:=1.1.4
+PKG_RELEASE:=1
+PKG_HASH:=8aba35bb9f2892be9092e8717d3e13604a817cdfb478dbc3855a226abc6c5979
+
+PKG_NAME:=php8-pecl-krb5
+PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://pecl.php.net/get/
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=php8
+PKG_BUILD_DIR:=$(BUILD_DIR)/pecl-php8/$(PECL_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include ../php8/pecl.mk
+
+CONFIGURE_ARGS+= \
+ --with-krb5=shared,"$(STAGING_DIR)/usr" \
+ --with-krb5config=$(STAGING_DIR)/usr/bin/krb5-config
+
+$(eval $(call PHP8PECLPackage,krb5,$(PECL_LONGNAME),+krb5-libs,30))
+$(eval $(call BuildPackage,$(PKG_NAME)))