aboutsummaryrefslogtreecommitdiff
path: root/lang/php8-pecl-http
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2021-12-09 08:07:19 +0100
committerMichael Heimpold <mhei@heimpold.de>2021-12-09 21:57:44 +0100
commit818957f3722ffecbd714ca712763d1d0dbe99ce2 (patch)
tree4faca4fba1fb340dbe64549083b714c6bc7597d4 /lang/php8-pecl-http
parent4e99a13ac8f1acc3dfcff86723e81dcbd34d3c2e (diff)
php7-pecl-http: migrate package to php8-pecl-http
Only a newer version of upstream includes support for PHP8, so while migrating we need to update to latest upstream version. We also need to adjust dependencies since JSON is now always integrated not longer available as dedicated package. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php8-pecl-http')
-rw-r--r--lang/php8-pecl-http/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/lang/php8-pecl-http/Makefile b/lang/php8-pecl-http/Makefile
new file mode 100644
index 000000000..c5ff0a52a
--- /dev/null
+++ b/lang/php8-pecl-http/Makefile
@@ -0,0 +1,58 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PECL_NAME:=pecl_http
+PECL_LONGNAME:=Extended HTTP Support
+
+PKG_VERSION:=4.2.1
+PKG_RELEASE:=1
+PKG_HASH:=ab07d55ccdfa897c897c26f1c0851b557b363431766c9ea4c799ea61443bdcdc
+
+PKG_NAME:=php8-pecl-http
+PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://pecl.php.net/get/
+
+PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
+
+PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=php8 php8-pecl-raphf
+PKG_BUILD_DIR:=$(BUILD_DIR)/pecl-php8/$(PECL_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include ../php8/pecl.mk
+
+CONFIGURE_VARS+= \
+ PECL_cv_HAVE_EXT_raphf=yes \
+ PECL_cv_HAVE_LIBCURL_ARES=no \
+ PECL_cv_HAVE_LIBCURL_OpenSSL=$(if $(CONFIG_LIBCURL_OPENSSL),yes,no) \
+ PECL_cv_HAVE_LIBCURL_GnuTLS=$(if $(CONFIG_LIBCURL_GNUTLS),yes,no) \
+ PECL_cv_HAVE_LIBCURL_NSS=no \
+ PECL_cv_HAVE_LIBCURL_SecureTransport=no \
+ PECL_cv_HAVE_LIBCURL_GSKit=no \
+ PECL_cv_HAVE_LIBCURL_PolarSSL=no \
+ PECL_cv_HAVE_LIBCURL_WolfSSL=$(if $(CONFIG_LIBCURL_WOLFSSL),yes,no) \
+ PECL_cv_HAVE_LIBCURL_mbedTLS=$(if $(CONFIG_LIBCURL_MBEDTLS),yes,no) \
+ PECL_cv_HAVE_LIBCURL_axTLS=no \
+ PECL_cv_LIBCURL_TLSAUTH_SRP=$(if $(CONFIG_LIBCURL_TLS_SRP),yes,no) \
+ PECL_cv_LIBCURL_SHARE_SSL=yes \
+
+CONFIGURE_ARGS+= \
+ --with-http \
+ --without-http-shared-deps \
+ --with-http-zlib-dir="$(STAGING_DIR)/usr" \
+ --with-http-libcurl-dir="$(STAGING_DIR)/usr" \
+ --with-http-libevent-dir="$(STAGING_DIR)/usr" \
+ --with-http-libidn-dir="$(STAGING_DIR)/usr" \
+ --with-http-libidnkit-dir=no \
+ --with-http-libidnkit2-dir=no
+
+$(eval $(call PHP8PECLPackage,http,$(PECL_LONGNAME),+icu +libcurl +librt +libevent2 +PACKAGE_libidn:libidn +libidn2 +php8-mod-iconv +php8-mod-session +php8-pecl-raphf,30))
+$(eval $(call BuildPackage,$(PKG_NAME)))