aboutsummaryrefslogtreecommitdiff
path: root/lang/php7
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2017-04-11 23:31:34 +0200
committerMichael Heimpold <mhei@heimpold.de>2017-04-11 23:31:37 +0200
commitcf75d8a0f975d646d6d1173561cd52c5184a15f2 (patch)
tree7edeedb1f416c0a141bbe9e2915fc9c265e44313 /lang/php7
parent4823feef13bd0ad8e5516da57687349deb072728 (diff)
php7: fix bind_textdomain_codeset detection (refs #4250)
The gettext extension is only useful when linked against libintl-full package, however, the detection did not work sucessfully. This patch by @Dimazhan fixes this. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php7')
-rw-r--r--lang/php7/Makefile2
-rw-r--r--lang/php7/patches/1006-fix-gettext.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index 73ced0673..f9ef6a166 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=7.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
diff --git a/lang/php7/patches/1006-fix-gettext.patch b/lang/php7/patches/1006-fix-gettext.patch
new file mode 100644
index 000000000..05d1ce9e0
--- /dev/null
+++ b/lang/php7/patches/1006-fix-gettext.patch
@@ -0,0 +1,11 @@
+--- a/ext/gettext/config.m4
++++ b/ext/gettext/config.m4
+@@ -32,3 +32,2 @@
+ )
+- LDFLAGS=$O_LDFLAGS
+
+@@ -48,3 +48,4 @@
+ AC_CHECK_LIB($GETTEXT_CHECK_IN_LIB, bind_textdomain_codeset, [AC_DEFINE(HAVE_BIND_TEXTDOMAIN_CODESET, 1, [ ])])
++ LDFLAGS=$O_LDFLAGS
+
+ fi