aboutsummaryrefslogtreecommitdiff
path: root/lang/php7
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2017-05-14 22:30:44 +0200
committerMichael Heimpold <mhei@heimpold.de>2017-05-14 22:31:25 +0200
commitb7eb92aada7ffa62a748922ee03f9641c56e0e53 (patch)
tree94c10ac962493bd268de970a477104bc26164e4b /lang/php7
parent529b00b5d4c1848d22bf6b4f407c4bc70d2be334 (diff)
php7: update to 7.1.5
Remove patch 1006-fix-gettext.patch which was integrated upstream. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php7')
-rw-r--r--lang/php7/Makefile8
-rw-r--r--lang/php7/patches/1006-fix-gettext.patch11
-rw-r--r--lang/php7/patches/1008-fix-musl-sys-headers.patch84
3 files changed, 44 insertions, 59 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index 2c3d2127e..1ff81bdb7 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -6,8 +6,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=php
-PKG_VERSION:=7.1.4
-PKG_RELEASE:=5
+PKG_VERSION:=7.1.5
+PKG_RELEASE:=1
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -16,8 +16,8 @@ PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_MD5SUM:=a74c13f8779349872b365e6732e8c98e
-PKG_HASH:=71514386adf3e963df087c2044a0b3747900b8b1fc8da3a99f0a0ae9180d300b
+PKG_MD5SUM:=fb0702321c7aceac68c82b8c7a10d196
+PKG_HASH:=d149a3c396c45611f5dc6bf14be190f464897145a76a8e5851cf18ff7094f6ac
PKG_FIXUP:=libtool autoreconf
PKG_BUILD_PARALLEL:=1
diff --git a/lang/php7/patches/1006-fix-gettext.patch b/lang/php7/patches/1006-fix-gettext.patch
deleted file mode 100644
index 05d1ce9e0..000000000
--- a/lang/php7/patches/1006-fix-gettext.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/ext/gettext/config.m4
-+++ b/ext/gettext/config.m4
-@@ -32,3 +32,2 @@
- )
-- LDFLAGS=$O_LDFLAGS
-
-@@ -48,3 +48,4 @@
- AC_CHECK_LIB($GETTEXT_CHECK_IN_LIB, bind_textdomain_codeset, [AC_DEFINE(HAVE_BIND_TEXTDOMAIN_CODESET, 1, [ ])])
-+ LDFLAGS=$O_LDFLAGS
-
- fi
diff --git a/lang/php7/patches/1008-fix-musl-sys-headers.patch b/lang/php7/patches/1008-fix-musl-sys-headers.patch
index f636a3606..dc6400261 100644
--- a/lang/php7/patches/1008-fix-musl-sys-headers.patch
+++ b/lang/php7/patches/1008-fix-musl-sys-headers.patch
@@ -1,6 +1,6 @@
---- a/configure.in 2017-04-14 11:53:48.345481008 -0600
-+++ b/configure.in 2017-04-14 11:58:47.887644651 -0600
-@@ -497,6 +497,7 @@
+--- a/configure.in
++++ b/configure.in
+@@ -494,6 +494,7 @@ limits.h \
locale.h \
monetary.h \
netdb.h \
@@ -8,59 +8,55 @@
pwd.h \
resolv.h \
signal.h \
-@@ -509,7 +510,6 @@
- sys/file.h \
- sys/mman.h \
- sys/mount.h \
--sys/poll.h \
- sys/resource.h \
- sys/select.h \
- sys/socket.h \
---- a/main/php_network.h 2017-04-11 09:37:35.000000000 -0600
-+++ b/main/php_network.h 2017-04-14 12:00:00.736168983 -0600
-@@ -122,8 +122,8 @@
- /* uncomment this to debug poll(2) emulation on systems that have poll(2) */
- /* #define PHP_USE_POLL_2_EMULATION 1 */
-
--#if defined(HAVE_SYS_POLL_H) && defined(HAVE_POLL)
--# include <sys/poll.h>
-+#if defined(HAVE_POLL_H) && defined(HAVE_POLL)
-+# include <poll.h>
- typedef struct pollfd php_pollfd;
- #else
- typedef struct _php_pollfd {
---- a/main/network.c 2017-04-11 09:37:35.000000000 -0600
-+++ b/main/network.c 2017-04-14 11:59:44.528052372 -0600
-@@ -51,8 +51,8 @@
- #ifdef HAVE_SYS_SELECT_H
- #include <sys/select.h>
- #endif
--#if HAVE_SYS_POLL_H
--#include <sys/poll.h>
-+#if HAVE_POLL_H
-+#include <poll.h>
- #endif
-
- #if defined(NETWARE)
---- a/main/fastcgi.c 2017-04-11 09:37:35.000000000 -0600
-+++ b/main/fastcgi.c 2017-04-14 12:01:06.924644901 -0600
-@@ -76,8 +76,8 @@
+--- a/main/fastcgi.c
++++ b/main/fastcgi.c
+@@ -76,7 +76,9 @@ static int is_impersonate = 0;
# include <netdb.h>
# include <signal.h>
-# if defined(HAVE_SYS_POLL_H) && defined(HAVE_POLL)
--# include <sys/poll.h>
+# if defined(HAVE_POLL_H) && defined(HAVE_POLL)
+# include <poll.h>
++# elif defined(HAVE_SYS_POLL_H) && defined(HAVE_POLL)
+ # include <sys/poll.h>
# endif
# if defined(HAVE_SYS_SELECT_H)
- # include <sys/select.h>
-@@ -1430,7 +1430,7 @@
+@@ -1427,7 +1429,7 @@ int fcgi_accept_request(fcgi_request *req)
break;
#else
if (req->fd >= 0) {
-#if defined(HAVE_SYS_POLL_H) && defined(HAVE_POLL)
-+#if defined(HAVE_POLL_H) && defined(HAVE_POLL)
++#if defined(HAVE_POLL)
struct pollfd fds;
int ret;
+--- a/main/network.c
++++ b/main/network.c
+@@ -51,7 +51,9 @@
+ #ifdef HAVE_SYS_SELECT_H
+ #include <sys/select.h>
+ #endif
+-#if HAVE_SYS_POLL_H
++#if HAVE_POLL_H
++#include <poll.h>
++#elif HAVE_SYS_POLL_H
+ #include <sys/poll.h>
+ #endif
+
+--- a/main/php_network.h
++++ b/main/php_network.h
+@@ -120,8 +120,12 @@ typedef int php_socket_t;
+ /* uncomment this to debug poll(2) emulation on systems that have poll(2) */
+ /* #define PHP_USE_POLL_2_EMULATION 1 */
+
+-#if defined(HAVE_SYS_POLL_H) && defined(HAVE_POLL)
+-# include <poll.h>
++#if defined(HAVE_POLL)
++# if defined(HAVE_POLL_H)
++# include <poll.h>
++# elif defined(HAVE_SYS_POLL_H)
++# include <sys/poll.h>
++# endif
+ typedef struct pollfd php_pollfd;
+ #else
+ typedef struct _php_pollfd {