aboutsummaryrefslogtreecommitdiff
path: root/lang/php7
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2017-11-26 21:58:30 +0100
committerMichael Heimpold <mhei@heimpold.de>2017-11-26 22:07:45 +0100
commit9a901e05e968c18fd3ae821f0b66b2222c17a4f7 (patch)
tree272940ed5fd427c79eb106d8dcde502386898329 /lang/php7
parent19653e57bf7062c30b9689a9a6fe50d39111b7c7 (diff)
php7: try to fix compilation on LEDE buildbots
Detection of U8T_DECOMPOSE seems to be broken when cross-compiling, so needs to be preseeded. -snip- checking for utf8_mime2text signature... new checking for U8T_DECOMPOSE... configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing. This should not happen. Check config.log for additional information. -snap- This requires also a patch for PHP to make the preseeding working. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php7')
-rw-r--r--lang/php7/Makefile1
-rw-r--r--lang/php7/patches/1007-ext-imap-config.m4-fix-ac_cv_u8t_decompose-check.patch35
2 files changed, 36 insertions, 0 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index d09c918df..9af3cbdf7 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -473,6 +473,7 @@ CONFIGURE_VARS+= \
php_cv_cc_rpath="no" \
iconv_impl_name="gnu_libiconv" \
ac_cv_php_xml2_config_path="$(STAGING_DIR)/host/bin/xml2-config" \
+ ac_cv_u8t_decompose=yes \
define Package/php7/conffiles
/etc/php.ini
diff --git a/lang/php7/patches/1007-ext-imap-config.m4-fix-ac_cv_u8t_decompose-check.patch b/lang/php7/patches/1007-ext-imap-config.m4-fix-ac_cv_u8t_decompose-check.patch
new file mode 100644
index 000000000..88b2db491
--- /dev/null
+++ b/lang/php7/patches/1007-ext-imap-config.m4-fix-ac_cv_u8t_decompose-check.patch
@@ -0,0 +1,35 @@
+From 96465be0f4ac225cfe6f52b809c91b9496807eac Mon Sep 17 00:00:00 2001
+From: Michael Heimpold <mhei@heimpold.de>
+Date: Sun, 26 Nov 2017 18:29:42 +0100
+Subject: [PATCH] ext/imap/config.m4: fix ac_cv_u8t_decompose check
+
+Once upon the time, commit c58f63a38ae19caaab339c61486fc3bd7e5894f9
+changed the check from U8T_CANONICAL to U8T_DECOMPOSE. However,
+the autoconf cache id was not renamed.
+
+Sometimes it is desirable to preseed the autoconf variables, e.g. when
+cross-compiling to avoid the tests running on the host system. In this
+case it's confusing when the cache id does not match the variable to
+set, so let's adjust it.
+
+Signed-off-by: Michael Heimpold <mhei@heimpold.de>
+---
+ ext/imap/config.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/imap/config.m4 b/ext/imap/config.m4
+index d0b86cb..badb6e2 100644
+--- a/ext/imap/config.m4
++++ b/ext/imap/config.m4
+@@ -147,7 +147,7 @@ if test "$PHP_IMAP" != "no"; then
+
+ old_CFLAGS=$CFLAGS
+ CFLAGS="-I$IMAP_INC_DIR"
+- AC_CACHE_CHECK(for U8T_DECOMPOSE, ac_cv_u8t_canonical,
++ AC_CACHE_CHECK(for U8T_DECOMPOSE, ac_cv_u8t_decompose,
+ AC_TRY_COMPILE([
+ #include <c-client.h>
+ ],[
+--
+2.7.4
+