aboutsummaryrefslogtreecommitdiff
path: root/lang/php7
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2017-12-22 22:00:20 +0100
committerMichael Heimpold <mhei@heimpold.de>2017-12-28 22:00:07 +0100
commit97305e41b61796869c1bd208d7532e0dc5e06fc0 (patch)
treefebc8c1722427ffffc5101f07f164b2b824baddf /lang/php7
parentf51dca14cd39a175460daa5ebbe4e6df8c1f12ab (diff)
php7: disable valgrind support
The check to enable/disable this new feature of PHP 7.2 works incorrectly when cross-compiling because it detects the host headers only and there is no way to pass in a dedicated directory. The wish to change this was reported upstream at: https://bugs.php.net/bug.php?id=75722 For the meantime, use a self-cooked patch. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php7')
-rw-r--r--lang/php7/Makefile1
-rw-r--r--lang/php7/patches/1008-acinclude-valgrind.patch42
2 files changed, 43 insertions, 0 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index bc930f094..2f4e56829 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -469,6 +469,7 @@ CONFIGURE_VARS+= \
iconv_impl_name="gnu_libiconv" \
ac_cv_php_xml2_config_path="$(STAGING_DIR)/host/bin/xml2-config" \
ac_cv_u8t_decompose=yes \
+ ac_cv_enable_valgrind_check=no \
define Package/php7/conffiles
/etc/php.ini
diff --git a/lang/php7/patches/1008-acinclude-valgrind.patch b/lang/php7/patches/1008-acinclude-valgrind.patch
new file mode 100644
index 000000000..a3eae9cf0
--- /dev/null
+++ b/lang/php7/patches/1008-acinclude-valgrind.patch
@@ -0,0 +1,42 @@
+--- a/acinclude.m4 2017-11-28 10:22:53.000000000 +0100
++++ b/acinclude.m4 2017-12-22 16:28:09.361331754 +0100
+@@ -3227,20 +3227,26 @@
+
+ dnl PHP_CHECK_VALGRIND
+ AC_DEFUN([PHP_CHECK_VALGRIND], [
+- AC_MSG_CHECKING([for valgrind])
++ AC_CACHE_CHECK(whether to enable the check for valgrind support,ac_cv_enable_valgrind_check,[
++ ac_cv_enable_valgrind_check=yes
++ ])
+
+- SEARCH_PATH="/usr/local /usr"
+- SEARCH_FOR="/include/valgrind/valgrind.h"
+- for i in $SEARCH_PATH ; do
+- if test -r $i/$SEARCH_FOR; then
+- VALGRIND_DIR=$i
+- fi
+- done
++ if test "$ac_cv_enable_valgrind_check" = "yes"; then
++ AC_MSG_CHECKING([for valgrind])
++
++ SEARCH_PATH="/usr/local /usr"
++ SEARCH_FOR="/include/valgrind/valgrind.h"
++ for i in $SEARCH_PATH ; do
++ if test -r $i/$SEARCH_FOR; then
++ VALGRIND_DIR=$i
++ fi
++ done
+
+- if test -z "$VALGRIND_DIR"; then
+- AC_MSG_RESULT([not found])
+- else
+- AC_MSG_RESULT(found in $VALGRIND_DIR)
+- AC_DEFINE(HAVE_VALGRIND, 1, [ ])
++ if test -z "$VALGRIND_DIR"; then
++ AC_MSG_RESULT([not found])
++ else
++ AC_MSG_RESULT(found in $VALGRIND_DIR)
++ AC_DEFINE(HAVE_VALGRIND, 1, [ ])
++ fi
+ fi
+ ])