aboutsummaryrefslogtreecommitdiff
path: root/lang/php7
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2016-09-21 21:47:08 +0200
committerMichael Heimpold <mhei@heimpold.de>2016-09-21 21:55:44 +0200
commit6d2d5a6a19107bf8c2ffa9d6f699e3ce36b32d1f (patch)
tree58289ed18c904418dad7ea03f2ecd5fac0ea3a12 /lang/php7
parentf71320e23321b031a87e1e5aa1c89cdbabcef924 (diff)
php7: package phar extension
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php7')
-rw-r--r--lang/php7/Makefile14
-rw-r--r--lang/php7/patches/1004-disable-phar-command.patch32
2 files changed, 42 insertions, 4 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index 1e5a0954b..64dd84365 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=7.0.10
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -35,7 +35,7 @@ PHP7_MODULES = \
ldap \
mbstring mcrypt mysqli \
opcache openssl \
- pcntl pdo pdo-mysql pdo-pgsql pdo-sqlite pgsql \
+ pcntl pdo pdo-mysql pdo-pgsql pdo-sqlite pgsql phar \
session shmop simplexml soap sockets sqlite3 sysvmsg sysvsem sysvshm \
tokenizer \
xml xmlreader xmlwriter zip \
@@ -157,8 +157,7 @@ CONFIGURE_ARGS+= \
--disable-short-tags \
\
--with-zlib="$(STAGING_DIR)/usr" \
- --with-zlib-dir="$(STAGING_DIR)/usr" \
- --disable-phar
+ --with-zlib-dir="$(STAGING_DIR)/usr"
ifneq ($(SDK)$(CONFIG_PACKAGE_php7-mod-calendar),)
CONFIGURE_ARGS+= --enable-calendar=shared
@@ -326,6 +325,12 @@ else
CONFIGURE_ARGS+= --without-pgsql
endif
+ifneq ($(SDK)$(CONFIG_PACKAGE_php7-mod-phar),)
+ CONFIGURE_ARGS+= --enable-phar=shared
+else
+ CONFIGURE_ARGS+= --disable-phar
+endif
+
ifneq ($(SDK)$(CONFIG_PACKAGE_php7-mod-session),)
CONFIGURE_ARGS+= --enable-session=shared
else
@@ -571,6 +576,7 @@ $(eval $(call BuildModule,pdo-mysql,PDO driver for MySQL,+php7-mod-pdo +PACKAGE_
$(eval $(call BuildModule,pdo-pgsql,PDO driver for PostgreSQL,+php7-mod-pdo +PACKAGE_php7-mod-pdo-pgsql:libpq))
$(eval $(call BuildModule,pdo-sqlite,PDO driver for SQLite 3.x,+php7-mod-pdo +PACKAGE_php7-mod-pdo-sqlite:libsqlite3 +PACKAGE_php7-mod-pdo-sqlite:librt))
$(eval $(call BuildModule,pgsql,PostgreSQL,+PACKAGE_php7-mod-pgsql:libpq))
+$(eval $(call BuildModule,phar,Phar Archives,+php7-mod-hash))
$(eval $(call BuildModule,session,Session))
$(eval $(call BuildModule,shmop,Shared Memory))
$(eval $(call BuildModule,simplexml,SimpleXML,+@PHP7_LIBXML +PACKAGE_php7-mod-simplexml:libxml2))
diff --git a/lang/php7/patches/1004-disable-phar-command.patch b/lang/php7/patches/1004-disable-phar-command.patch
new file mode 100644
index 000000000..19837f53f
--- /dev/null
+++ b/lang/php7/patches/1004-disable-phar-command.patch
@@ -0,0 +1,32 @@
+--- a/ext/phar/config.m4 2016-08-17 21:50:58.000000000 +0200
++++ b/ext/phar/config.m4 2016-09-20 22:21:28.494934775 +0200
+@@ -26,7 +26,7 @@
+ fi
+ PHP_ADD_EXTENSION_DEP(phar, hash, true)
+ PHP_ADD_EXTENSION_DEP(phar, spl, true)
+- PHP_ADD_MAKEFILE_FRAGMENT
++ #PHP_ADD_MAKEFILE_FRAGMENT
+
+ PHP_INSTALL_HEADERS([ext/phar], [php_phar.h])
+
+--- a/configure.in 2016-09-20 22:26:38.000000000 +0200
++++ b/configure.in 2016-09-20 22:42:30.380101556 +0200
+@@ -1448,13 +1448,13 @@
+ INLINE_CFLAGS="$INLINE_CFLAGS $standard_libtool_flag"
+ CXXFLAGS="$CXXFLAGS $standard_libtool_flag \$(PROF_FLAGS)"
+
+-if test "$PHP_PHAR" != "no" && test "$PHP_CLI" != "no"; then
+- pharcmd=pharcmd
+- pharcmd_install=install-pharcmd
+-else
++#if test "$PHP_PHAR" != "no" && test "$PHP_CLI" != "no"; then
++# pharcmd=pharcmd
++# pharcmd_install=install-pharcmd
++#else
+ pharcmd=
+ pharcmd_install=
+-fi;
++#fi;
+
+ all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_BINARIES) $pharcmd"
+ install_targets="$install_sapi $install_modules $install_binaries install-build install-headers install-programs $install_pear $pharcmd_install"