aboutsummaryrefslogtreecommitdiff
path: root/lang/php7
diff options
context:
space:
mode:
authorVal Kulkov <val.kulkov@gmail.com>2017-11-10 19:04:59 -0500
committerVal Kulkov <val.kulkov@gmail.com>2017-11-10 19:50:34 -0500
commit50308e4fd7c84fa027f5fe3b8101e8853046bd5f (patch)
tree4a20feb9947d2bdd9fa771480777521c0a0d4a4f /lang/php7
parentdbec5d9f69a1dd0db6747072fd639b9e64e4ac44 (diff)
php7: add configuration files to conffiles
Two important configuration files, /etc/php7-fpm.conf and /etc/php7-fpm.d/www.conf are silently overwritten on each php7-fpm upgrade or lost on a sysupgrade. This commit adds the conffiles section for php7-fpm and revises the conffiles section for php7. Signed-off-by: Val Kulkov <val.kulkov@gmail.com>
Diffstat (limited to 'lang/php7')
-rw-r--r--lang/php7/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index d6bf3308b..82c364b10 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=7.1.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -457,6 +457,7 @@ CONFIGURE_VARS+= \
define Package/php7/conffiles
/etc/php.ini
+/etc/php7/
endef
define Package/php7/install
@@ -500,6 +501,12 @@ define Package/php7-fpm/install
$(INSTALL_BIN) ./files/php7-fpm.init $(1)/etc/init.d/php7-fpm
endef
+define Package/php7-fpm/conffiles
+/etc/php7-fpm.conf
+/etc/php7-fpm.d/
+/etc/config/php7-fpm
+endef
+
define Build/Prepare
$(call Build/Prepare/Default)
( cd $(PKG_BUILD_DIR); touch configure.in; ./buildconf --force )