aboutsummaryrefslogtreecommitdiff
path: root/lang/php7
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2017-04-18 00:12:20 +0200
committerMichael Heimpold <mhei@heimpold.de>2017-04-18 00:12:28 +0200
commit4dd144c1bd8028eda59c17a5debd1a8f882c9e1d (patch)
treea8dc5a6072a3c69428f29fd57f92b5627ecc2fd1 /lang/php7
parentc401946b0e039b53a8865cd0f78d26149f767305 (diff)
php7: fix build of php7-mod-intl
This fixes the following build error (shortened paths for readability): -snip- In file included from .../php-7.1.4/ext/intl/intl_convertcpp.h:26:0, from .../php-7.1.4/ext/intl/intl_convertcpp.cpp:21: .../staging_dir/target-arm_arm926ej-s_musl_eabi/usr/include/unicode/unistr.h:56:16: error: 'UChar' does not name a type u_strlen(const UChar *s); ^ .../staging_dir/target-arm_arm926ej-s_musl_eabi/usr/include/unicode/unistr.h:80:19: error: 'char16_t' has not been declared char16_t *dest, int32_t destCapacity, ^ .../staging_dir/target-arm_arm926ej-s_musl_eabi/usr/include/unicode/unistr.h:81:25: error: 'char16_t' does not name a type const char16_t *src, int32_t srcLength, ^ In file included from .../php-7.1.4/ext/intl/intl_convertcpp.h:26:0, from .../php-7.1.4/ext/intl/intl_convertcpp.cpp:21: .../staging_dir/target-arm_arm926ej-s_musl_eabi/usr/include/unicode/unistr.h:462:16: error: 'char16_t' does not name a type const char16_t *srcChars) const; ^ [...] -snap- This build error was introduced by update of icu to 59.1. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php7')
-rw-r--r--lang/php7/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index feb7ad1ea..71ac992e6 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=7.1.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -245,6 +245,7 @@ endif
ifneq ($(SDK)$(CONFIG_PACKAGE_php7-mod-intl),)
CONFIGURE_ARGS+= --enable-intl=shared
+ TARGET_CPPFLAGS+= -std=c++0x
else
CONFIGURE_ARGS+= --disable-intl
endif