aboutsummaryrefslogtreecommitdiff
path: root/lang/php7
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2016-09-06 21:51:54 +0200
committerMichael Heimpold <mhei@heimpold.de>2016-09-06 21:58:34 +0200
commit3d305a35e1cd02e370c056c1e83ec162a9045101 (patch)
treeaf75173e718784636484a882b831aeb2d3c3a193 /lang/php7
parent52ab5cbc5b69f346c3960007ea9be393e855dc1e (diff)
php7/php7-pecl-*: introduce load order
Some PECL modules (possibly also php modules) depend on special load order, otherwise loading the module will fail due to unresolvable symbols. This changeset introduces a very simple compile-time defined order by specifying a prefix for the ini file with the load directive. If not given, it uses a default value. It also updates all current pecl module packages to take this new approach. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php7')
-rw-r--r--lang/php7/Makefile10
-rw-r--r--lang/php7/pecl.mk6
2 files changed, 8 insertions, 8 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index 82e73fe9d..1e5a0954b 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=7.0.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -527,10 +527,10 @@ define BuildModule
$(INSTALL_DIR) $$(1)/usr/lib/php
$(INSTALL_BIN) $(PKG_BUILD_DIR)/modules/$(subst -,_,$(1)).so $$(1)/usr/lib/php/
$(INSTALL_DIR) $$(1)/etc/php7
- ifeq ($(4),zend)
- echo "zend_extension=/usr/lib/php/$(subst -,_,$(1)).so" > $$(1)/etc/php7/$(subst -,_,$(1)).ini
+ ifeq ($(5),zend)
+ echo "zend_extension=/usr/lib/php/$(subst -,_,$(1)).so" > $$(1)/etc/php7/$(if $(4),$(4),20)_$(subst -,_,$(1)).ini
else
- echo "extension=$(subst -,_,$(1)).so" > $$(1)/etc/php7/$(subst -,_,$(1)).ini
+ echo "extension=$(subst -,_,$(1)).so" > $$(1)/etc/php7/$(if $(4),$(4),20)_$(subst -,_,$(1)).ini
endif
endef
@@ -563,7 +563,7 @@ $(eval $(call BuildModule,ldap,LDAP,+PACKAGE_php7-mod-ldap:libopenldap +PACKAGE_
$(eval $(call BuildModule,mbstring,MBString))
$(eval $(call BuildModule,mcrypt,Mcrypt,+PACKAGE_php7-mod-mcrypt:libmcrypt +PACKAGE_php7-mod-mcrypt:libltdl))
$(eval $(call BuildModule,mysqli,MySQL Improved Extension,+PACKAGE_php7-mod-mysqli:libmysqlclient))
-$(eval $(call BuildModule,opcache,OPcache,,zend))
+$(eval $(call BuildModule,opcache,OPcache,,,zend))
$(eval $(call BuildModule,openssl,OpenSSL,+PACKAGE_php7-mod-openssl:libopenssl))
$(eval $(call BuildModule,pcntl,PCNTL))
$(eval $(call BuildModule,pdo,PHP Data Objects))
diff --git a/lang/php7/pecl.mk b/lang/php7/pecl.mk
index 79715560e..7b7c2442b 100644
--- a/lang/php7/pecl.mk
+++ b/lang/php7/pecl.mk
@@ -34,10 +34,10 @@ define PECLPackage
$(INSTALL_DIR) $$(1)/usr/lib/php
$(INSTALL_BIN) $(PKG_BUILD_DIR)/modules/$(subst -,_,$(1)).so $$(1)/usr/lib/php/
$(INSTALL_DIR) $$(1)/etc/php7
- ifeq ($(4),zend)
- echo "zend_extension=/usr/lib/php/$(subst -,_,$(1)).so" > $$(1)/etc/php7/$(subst -,_,$(1)).ini
+ ifeq ($(5),zend)
+ echo "zend_extension=/usr/lib/php/$(subst -,_,$(1)).so" > $$(1)/etc/php7/$(if $(4),$(4),20)_$(subst -,_,$(1)).ini
else
- echo "extension=$(subst -,_,$(1)).so" > $$(1)/etc/php7/$(subst -,_,$(1)).ini
+ echo "extension=$(subst -,_,$(1)).so" > $$(1)/etc/php7/$(if $(4),$(4),20)_$(subst -,_,$(1)).ini
endif
endef