aboutsummaryrefslogtreecommitdiff
path: root/lang/php7
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2016-12-23 22:57:28 +0100
committerMichael Heimpold <mhei@heimpold.de>2016-12-23 23:08:29 +0100
commit333957fba91346093b8d622b2a3611bdf60a4367 (patch)
tree9ccde8a98cb2eabdae8c4a890a84417bc2321f75 /lang/php7
parent96d5c779b2b27231f465942294d827f2f18571d8 (diff)
php7-pecl-http: fix build for big endian (fixes #3691)
While at, improve pre-seeded dependency detection. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang/php7')
-rw-r--r--lang/php7/pecl.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/php7/pecl.mk b/lang/php7/pecl.mk
index 7b7c2442b..caafc66c3 100644
--- a/lang/php7/pecl.mk
+++ b/lang/php7/pecl.mk
@@ -16,6 +16,9 @@ define Build/Prepare
( cd $(PKG_BUILD_DIR); $(STAGING_DIR)/usr/bin/phpize7 )
endef
+CONFIGURE_VARS+= \
+ ac_cv_c_bigendian_php=$(if $(CONFIG_BIG_ENDIAN),yes,no)
+
CONFIGURE_ARGS+= \
--with-php-config=$(STAGING_DIR)/usr/bin/php7-config