aboutsummaryrefslogtreecommitdiff
path: root/lang/perl
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-02-27 23:24:23 -0800
committerRosen Penev <rosenp@gmail.com>2022-03-02 16:30:32 -0800
commit59980b6be79546acb4a9c69c92cd7bfdb4450785 (patch)
tree68122fd26b7e1ab45a2adf7f0db5ac748d6eccdf /lang/perl
parent68fb9c62a5f4421650aabb33c53466709afc46d6 (diff)
perl: add powerpc64 support
Needed by the QoriQ target. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'lang/perl')
-rw-r--r--lang/perl/Makefile2
-rw-r--r--lang/perl/files/powerpc64.config20
2 files changed, 21 insertions, 1 deletions
diff --git a/lang/perl/Makefile b/lang/perl/Makefile
index 443164f0a..99302cb1a 100644
--- a/lang/perl/Makefile
+++ b/lang/perl/Makefile
@@ -11,7 +11,7 @@ include perlver.mk
PKG_NAME:=perl
PKG_VERSION:=$(PERL_VERSION)
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE_URL:=\
https://cpan.metacpan.org/src/5.0 \
diff --git a/lang/perl/files/powerpc64.config b/lang/perl/files/powerpc64.config
new file mode 100644
index 000000000..3bd432077
--- /dev/null
+++ b/lang/perl/files/powerpc64.config
@@ -0,0 +1,20 @@
+owrt:arch=powerpc
+owrt:bits=64
+owrt:endian=big
+
+ccsymbols='__gnu_linux__=1 __linux=1 __linux__=1 __unix=1 __unix__=1 system=linux system=posix system=unix'
+cppccsymbols='linux=1 unix=1'
+cppsymbols='_BIG_ENDIAN=1 __BIG_ENDIAN__=1 __ELF__=1 _FILE_OFFSET_BITS=64 __GLIBC__=2 __GLIBC_MINOR__=2 __GNUC__=3 __GNUC_MINOR__=4 __GNU_LIBRARY__=6 _LARGEFILE_SOURCE=1 _POSIX_C_SOURCE=199506L _POSIX_SOURCE=1 __STDC__=1 __USE_BSD=1 __USE_FILE_OFFSET64=1 __USE_LARGEFILE=1 __USE_MISC=1 __USE_POSIX=1 __USE_POSIX199309=1 __USE_POSIX199506=1 __USE_POSIX2=1 __USE_SVID=1 __linux=1 __linux__=1 __unix=1 __unix__=1'
+d_casti32='undef'
+d_double_style_ieee='define'
+d_modflproto='undef'
+doublekind='4'
+fpossize='24'
+longdblkind='0'
+need_va_copy='define'
+quadkind='3'
+
+owrt:sig_count='64'
+owrt:sigs='ZERO HUP INT QUIT ILL TRAP ABRT BUS FPE KILL USR1 SEGV USR2 PIPE ALRM TERM STKFLT CHLD CONT STOP TSTP TTIN TTOU URG XCPU XFSZ VTALRM PROF WINCH IO PWR SYS'
+owrt:sig_name_extra='IOT CLD POLL UNUSED'
+owrt:sig_num_extra='6 17 29 31'