aboutsummaryrefslogtreecommitdiff
path: root/lang/perl
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-08-11 10:57:23 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2021-08-11 16:59:20 -0300
commit19c7496648cb25500ca7007a7c1578a426c23a09 (patch)
tree27f9ffc931549b925a6108cd24f222f2dd747242 /lang/perl
parent0e4e08ff24916a460b017323fa7a56f8677407ae (diff)
perl: perlmod.mk: use 'install' for host binaries
When installing a host perl module, the host perl binary in the staging dir is replaced by using 'cp'. However, if the binary is running in a parallel job, cp will fail with a text file busy error. Use $(INSTALL_BIN), which unliks the file first to avoid the error. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'lang/perl')
-rw-r--r--lang/perl/perlmod.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/perl/perlmod.mk b/lang/perl/perlmod.mk
index 8a9509915..2ce3ceab0 100644
--- a/lang/perl/perlmod.mk
+++ b/lang/perl/perlmod.mk
@@ -35,8 +35,8 @@ PERLMOD_TESTSDIR:=/usr/share/perl/perlmod-tests
define perlmod/host/relink
rm -f $(1)/Makefile.aperl
$(MAKE) -C $(1) perl
- $(CP) $(1)/perl $(PERL_CMD)
- $(CP) $(1)/perl $(STAGING_DIR_HOSTPKG)/usr/bin/perl
+ $(INSTALL_BIN) $(1)/perl $(PERL_CMD)
+ $(INSTALL_BIN) $(1)/perl $(STAGING_DIR_HOSTPKG)/usr/bin/perl
endef
define perlmod/host/Configure