aboutsummaryrefslogtreecommitdiff
path: root/lang/perl/perlver.mk
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2018-08-07 16:00:19 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2018-08-13 13:23:11 -0600
commit0d9584724ff1c011f587540c2d25be8a90a81413 (patch)
treea1e92a5d4e41f0e5ae5953abdfd76dbf59e93582 /lang/perl/perlver.mk
parent7f71fa5a8dd55a4b003848adbdb1bb65c6af67bb (diff)
perl: version modules and non-base packages
Currently external modules and non-base packages are numbered from their own internal number space, and even though the Perl ABI number is embedded into them this isn't externally visible. For example, perl-html-parser-3.72.1 could be built for ABI 5.26 or for 5.28, we can't easily tell. This changes all of that by embedding the ABI number into the filename. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'lang/perl/perlver.mk')
-rw-r--r--lang/perl/perlver.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/lang/perl/perlver.mk b/lang/perl/perlver.mk
new file mode 100644
index 000000000..b23e68a20
--- /dev/null
+++ b/lang/perl/perlver.mk
@@ -0,0 +1,10 @@
+PERL_VERSION:=5.28.0
+
+PERL_EXPLODE:=$(subst ., ,$(PERL_VERSION))
+
+PERL_MAJOR:=$(word 1,$(PERL_EXPLODE))
+PERL_MINOR:=$(word 2,$(PERL_EXPLODE))
+PERL_REL:=$(word 3,$(PERL_EXPLODE))
+
+PERL_VERSION3:=$(PERL_VERSION)
+PERL_VERSION2:=$(PERL_MAJOR).$(PERL_MINOR)