aboutsummaryrefslogtreecommitdiff
path: root/lang/perl/perlmod.mk
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2018-09-23 13:36:37 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2018-09-23 14:19:51 -0600
commita5a4eafc930407dc082432acf50721598af84939 (patch)
tree8503b709319d8c2c3a726ce8197cece87597a28d /lang/perl/perlmod.mk
parent53a912201c74c87d088fa29421719e49ec424365 (diff)
perlmod: fix ability to build module out-of-feed
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'lang/perl/perlmod.mk')
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/perl/perlmod.mk b/lang/perl/perlmod.mk
index d00a8c42e..8a9509915 100644
--- a/lang/perl/perlmod.mk
+++ b/lang/perl/perlmod.mk
@@ -1,7 +1,11 @@
# This makefile simplifies perl module builds.
#
-include ../perl/perlver.mk
+ifeq ($(origin PERL_INCLUDE_DIR),undefined)
+ PERL_INCLUDE_DIR:=$(dir $(lastword $(MAKEFILE_LIST)))
+endif
+
+include $(PERL_INCLUDE_DIR)/perlver.mk
ifneq ($(PKG_NAME),perl)
PKG_VERSION:=$(PKG_VERSION)+perl$(PERL_VERSION2)