aboutsummaryrefslogtreecommitdiff
path: root/lang/perl-uri/Makefile
diff options
context:
space:
mode:
authorMarcel Denia <naoir@gmx.net>2014-07-16 00:18:50 +0200
committerMarcel Denia <naoir@gmx.net>2014-07-23 09:32:24 +0200
commit2fc7cf44028e370163c16de92aad7a27d1e8f596 (patch)
tree37c110b48eeafbfe23c1ae323bae81eb0ee1648a /lang/perl-uri/Makefile
parent5092ba67809c36f7bf09429c512bf8c68820f043 (diff)
Import of oldpackages/perl-*
Signed-off-by: Marcel Denia <naoir@gmx.net>
Diffstat (limited to 'lang/perl-uri/Makefile')
-rw-r--r--lang/perl-uri/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/lang/perl-uri/Makefile b/lang/perl-uri/Makefile
new file mode 100644
index 000000000..d6938bfbd
--- /dev/null
+++ b/lang/perl-uri/Makefile
@@ -0,0 +1,39 @@
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=perl-uri
+PKG_VERSION:=1.36
+PKG_RELEASE:=1
+PKG_MD5SUM:=a97bbdd38b31c6b2672fdc3060fae34b
+
+PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/G/GA/GAAS
+PKG_SOURCE:=URI-$(PKG_VERSION).tar.gz
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/URI-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../perl/perlmod.mk
+
+define Package/perl-uri
+SUBMENU:=Perl
+SECTION:=lang
+CATEGORY:=Languages
+TITLE:=Manipulates and accesses URI strings
+URL:=http://search.cpan.org/dist/URI/
+DEPENDS:=perl
+endef
+
+define Build/Configure
+ $(call perlmod/Configure,,)
+endef
+
+define Build/Compile
+ $(call perlmod/Compile,,)
+endef
+
+define Package/perl-uri/install
+ $(call perlmod/Install,$(1),URI URI.pm)
+endef
+
+
+$(eval $(call BuildPackage,perl-uri))