aboutsummaryrefslogtreecommitdiff
path: root/lang/perl-authen-sasl
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-12-31 15:16:05 -0700
committerPhilip Prindeville <philipp@redfish-solutions.com>2018-02-13 11:35:41 -0700
commit184cb956b1fb20d783adb3fb1abca83324c1deeb (patch)
tree042386157f76622c752ecec928ba6091e09223e6 /lang/perl-authen-sasl
parent59c979d595f21152c313fa895ba62c8a6b3891e9 (diff)
perl: add Authen::SASL module
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'lang/perl-authen-sasl')
-rw-r--r--lang/perl-authen-sasl/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/lang/perl-authen-sasl/Makefile b/lang/perl-authen-sasl/Makefile
new file mode 100644
index 000000000..434ec088b
--- /dev/null
+++ b/lang/perl-authen-sasl/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2017 Philip Prindeville <philipp@redfish-solutions.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=perl-authen-sasl
+PKG_VERSION:=2.16
+PKG_RELEASE:=1
+
+PKG_SOURCE_NAME:=Authen-SASL
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/G/GB/GBARR/
+PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.gz
+PKG_HASH:=6614fa7518f094f853741b63c73f3627168c5d3aca89b1d02b1016dc32854e09
+
+PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
+PKG_MAINTAINER:=Philip Prindeville <philipp@redfish-solutions.com>
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../perl/perlmod.mk
+
+define Package/perl-authen-sasl
+ SUBMENU:=Perl
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Generic network authentication protocol framework.
+ URL:=http://search.cpan.org/dist/$(PKG_SOURCE_NAME)/
+ DEPENDS:=perl +perlbase-digest
+endef
+
+define Build/Configure
+ $(call perlmod/Configure,,)
+endef
+
+define Build/Compile
+ $(call perlmod/Compile,,)
+endef
+
+define Package/perl-authen-sasl/install
+ $(call perlmod/Install,$(1),Authen)
+endef
+
+
+$(eval $(call BuildPackage,perl-authen-sasl))