aboutsummaryrefslogtreecommitdiff
path: root/lang/node
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2023-03-20 17:33:17 +0900
committerTianling Shen <cnsztl@gmail.com>2023-03-21 17:29:35 +0800
commit94345b0325bbffebf97b8a54f2d896a1bbb1291a (patch)
tree659e8a26dd0cf427c08b67e1497a875a32732b16 /lang/node
parenta4b9697684ad13e9c60e22a830c5d5c28bd5e9ad (diff)
node: bump to v18.15.0
Update to v18.15.0 Fixed bug using system-icu Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
Diffstat (limited to 'lang/node')
-rw-r--r--lang/node/Makefile4
-rw-r--r--lang/node/patches/990-delete_unnecessary_libraries_for_host_execute.patch6
-rw-r--r--lang/node/patches/991-v8_zlib_support.patch4
-rw-r--r--lang/node/patches/992-v8_add_include_dirs.patch26
-rw-r--r--lang/node/patches/992-v8_compiler_add_include_dirs.patch10
5 files changed, 33 insertions, 17 deletions
diff --git a/lang/node/Makefile b/lang/node/Makefile
index f1eacd891..6da85cc12 100644
--- a/lang/node/Makefile
+++ b/lang/node/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=node
-PKG_VERSION:=v18.14.2
+PKG_VERSION:=v18.15.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
-PKG_HASH:=fbc364dd25fee2cacc0f2033db2d86115fc07575310ea0e64408b8170d09c685
+PKG_HASH:=8e44d65018ff973284195c23186469a0ea4082e97ec4200e5f5706d5584daa37
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
PKG_LICENSE:=MIT
diff --git a/lang/node/patches/990-delete_unnecessary_libraries_for_host_execute.patch b/lang/node/patches/990-delete_unnecessary_libraries_for_host_execute.patch
index f9e5329db..d9b5b6889 100644
--- a/lang/node/patches/990-delete_unnecessary_libraries_for_host_execute.patch
+++ b/lang/node/patches/990-delete_unnecessary_libraries_for_host_execute.patch
@@ -51,7 +51,7 @@
'dependencies': [
'v8_base_without_compiler',
'v8_compiler_for_mksnapshot',
-@@ -1442,6 +1445,7 @@
+@@ -1450,6 +1453,7 @@
{
'target_name': 'torque',
'type': 'executable',
@@ -59,7 +59,7 @@
'dependencies': [
'torque_base',
# "build/win:default_exe_manifest",
-@@ -1480,6 +1484,7 @@
+@@ -1488,6 +1492,7 @@
{
'target_name': 'torque-language-server',
'type': 'executable',
@@ -67,7 +67,7 @@
'conditions': [
['want_separate_host_toolset', {
'toolsets': ['host'],
-@@ -1507,6 +1512,8 @@
+@@ -1515,6 +1520,8 @@
{
'target_name': 'gen-regexp-special-case',
'type': 'executable',
diff --git a/lang/node/patches/991-v8_zlib_support.patch b/lang/node/patches/991-v8_zlib_support.patch
index d8c478b8f..cc400a36e 100644
--- a/lang/node/patches/991-v8_zlib_support.patch
+++ b/lang/node/patches/991-v8_zlib_support.patch
@@ -62,7 +62,7 @@
'include_dirs': [
'<(V8_ROOT)/include',
],
-@@ -1729,6 +1736,7 @@
+@@ -1737,6 +1744,7 @@
}],
],
'direct_dependent_settings': {
@@ -70,7 +70,7 @@
'include_dirs': [
'<(V8_ROOT)/include',
],
-@@ -1909,15 +1917,19 @@
+@@ -1917,15 +1925,19 @@
}],
],
'direct_dependent_settings': {
diff --git a/lang/node/patches/992-v8_add_include_dirs.patch b/lang/node/patches/992-v8_add_include_dirs.patch
new file mode 100644
index 000000000..8588621d2
--- /dev/null
+++ b/lang/node/patches/992-v8_add_include_dirs.patch
@@ -0,0 +1,26 @@
+--- a/tools/v8_gypfiles/v8.gyp
++++ b/tools/v8_gypfiles/v8.gyp
+@@ -242,6 +242,7 @@
+ 'sources': [
+ '<(V8_ROOT)/src/init/setup-isolate-full.cc',
+ ],
++ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
+ }, # v8_init
+ {
+ 'target_name': 'v8_initializers',
+@@ -714,6 +715,7 @@
+ 'v8_shared_internal_headers',
+ ],
+ 'sources': ['<@(v8_compiler_sources)'],
++ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
+ 'conditions': [
+ ['OS=="win"', {
+ 'msvs_precompiled_header': '<(V8_ROOT)/../../tools/msvs/pch/v8_pch.h',
+@@ -1431,6 +1433,7 @@
+ 'type': 'executable',
+ 'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
+ 'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
++ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
+ 'dependencies': [
+ 'v8_base_without_compiler',
+ 'v8_compiler_for_mksnapshot',
diff --git a/lang/node/patches/992-v8_compiler_add_include_dirs.patch b/lang/node/patches/992-v8_compiler_add_include_dirs.patch
deleted file mode 100644
index c80cea038..000000000
--- a/lang/node/patches/992-v8_compiler_add_include_dirs.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/tools/v8_gypfiles/v8.gyp
-+++ b/tools/v8_gypfiles/v8.gyp
-@@ -714,6 +714,7 @@
- 'v8_shared_internal_headers',
- ],
- 'sources': ['<@(v8_compiler_sources)'],
-+ 'include_dirs': [ '<!@(echo "$STAGING_DIR"/usr/../usr/include)' ],
- 'conditions': [
- ['OS=="win"', {
- 'msvs_precompiled_header': '<(V8_ROOT)/../../tools/msvs/pch/v8_pch.h',