aboutsummaryrefslogtreecommitdiff
path: root/lang/node
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-04-25 11:02:22 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2019-04-26 21:11:12 -0300
commit8c1d86baad676d50b150535bff5609ab322115bb (patch)
tree1877a519cfed77f56bd41b7d678bf535a1cd336d /lang/node
parent1d00dab07eb8c32513d634aef17394613f2cce96 (diff)
node: don't build on unsupported cpus, remove menu
Node does not support arc or armeb systems. Moved i18 option to straight under node instead of on its own menu. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'lang/node')
-rw-r--r--lang/node/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/lang/node/Makefile b/lang/node/Makefile
index b807cc9ef..25816a893 100644
--- a/lang/node/Makefile
+++ b/lang/node/Makefile
@@ -37,7 +37,10 @@ define Package/node
SUBMENU:=Node.js
TITLE:=Node.js is a platform built on Chrome's JavaScript runtime
URL:=https://nodejs.org/
- DEPENDS:=@(HAS_FPU||KERNEL_MIPS_FPU_EMULATOR) +libstdcpp +libopenssl +zlib +libnghttp2 +libuv +libhttp-parser +USE_UCLIBC:libpthread +USE_UCLIBC:librt +NODEJS_ICU:icu
+ DEPENDS:=@(HAS_FPU||KERNEL_MIPS_FPU_EMULATOR) @!arc @!armeb \
+ +libstdcpp +libopenssl +zlib +libnghttp2 +libuv +libhttp-parser \
+ +USE_UCLIBC:libpthread +USE_UCLIBC:librt \
+ +NODEJS_ICU:icu
endef
define Package/node/description
@@ -60,13 +63,13 @@ define Package/node-npm/description
endef
define Package/node/config
- menu "Module Selection"
+ if PACKAGE_node
config NODEJS_ICU
bool "enable i18n features"
default n
- endmenu
+ endif
endef
NODEJS_CPU:=$(subst powerpc,ppc,$(subst aarch64,arm64,$(subst x86_64,x64,$(subst i386,ia32,$(ARCH)))))