aboutsummaryrefslogtreecommitdiff
path: root/lang/node/Makefile
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2023-11-01 10:03:48 +0900
committerTianling Shen <cnsztl@gmail.com>2023-11-02 00:25:22 +0800
commit3e51eef14c3be57d1a5ac3c1ecd4150aa5d8e639 (patch)
treefea01ea62e039ad07dca8673efeab9dad158f5f2 /lang/node/Makefile
parent2d864d2a6bb1ee9c7c48bac72490e314ae84e42d (diff)
node: upgrade to v20.9.0
node.js version 20.x is now active LTS. mipsel (pistachio) is no longer supported. Due to build difficulties, libuv shared libraries are not used. Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
Diffstat (limited to 'lang/node/Makefile')
-rw-r--r--lang/node/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/lang/node/Makefile b/lang/node/Makefile
index e93590b5d..692bedf38 100644
--- a/lang/node/Makefile
+++ b/lang/node/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=node
-PKG_VERSION:=v18.18.2
+PKG_VERSION:=v20.9.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
-PKG_HASH:=7249e2f0af943ec38599504f4b2a2bd31fb938787291b6ccca6c8badf01e3b56
+PKG_HASH:=a23d96810abf0455426b349d47ce5310f33095b7bc0571b9cc510f481c3a4519
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
PKG_LICENSE:=MIT
@@ -26,7 +26,6 @@ HOST_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=python3/host
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
-PKG_BUILD_FLAGS:=no-mips16
PKG_ASLR_PIE:=0
include $(INCLUDE_DIR)/host-build.mk
@@ -38,8 +37,8 @@ define Package/node
SUBMENU:=Node.js
TITLE:=Node.js is a platform built on Chrome's JavaScript runtime
URL:=https://nodejs.org/
- DEPENDS:=@HAS_FPU @(i386||x86_64||arm||aarch64||mipsel) \
- +libstdcpp +libopenssl +zlib +libnghttp2 +libuv \
+ DEPENDS:=@HAS_FPU @(i386||x86_64||arm||aarch64) \
+ +libstdcpp +libopenssl +zlib +libnghttp2 \
+libcares +libatomic +NODEJS_ICU_SYSTEM:icu +NODEJS_ICU_SYSTEM:icu-full-data
endef
@@ -47,8 +46,9 @@ define Package/node/description
Node.jsĀ® is a JavaScript runtime built on Chrome's V8 JavaScript engine. Node.js uses
an event-driven, non-blocking I/O model that makes it lightweight and efficient. Node.js'
package ecosystem, npm, is the largest ecosystem of open source libraries in the world.
+
*** The following preparations must be made on the host side. ***
- 1. gcc 8.3 or higher is required.
+ 1. gcc 10.1 or higher is required.
2. To build a 32-bit target, gcc-multilib, g++-multilib are required.
3. Requires libatomic package. (If necessary, install the 32-bit library at the same time.)
ex) sudo apt-get install gcc-multilib g++-multilib
@@ -115,7 +115,6 @@ CONFIGURE_ARGS:= \
--shared-zlib \
--shared-openssl \
--shared-nghttp2 \
- --shared-libuv \
--shared-cares \
--with-intl=$(if $(CONFIG_NODEJS_ICU_SMALL),small-icu,$(if $(CONFIG_NODEJS_ICU_SYSTEM),system-icu,none)) \
$(if $(findstring +neon",$(CONFIG_CPU_TYPE)),--with-arm-fpu=neon) \
@@ -157,7 +156,11 @@ define Package/node-npm/install
endef
define Host/Install
- $(RM) -rf $(1)/lib/node_modules/npm
+ rm -f $(1)/bin/npm
+ rm -f $(1)/bin/npx
+ rm -rf $(1)/lib/node_modules/npm
+ rm -f $(1)/bin/corepack
+ rm -rf $(1)/lib/node_modules/corepack
$(call Host/Install/Default)
endef