aboutsummaryrefslogtreecommitdiff
path: root/lang/luasocket
diff options
context:
space:
mode:
authorJan Čermák <jan.cermak@nic.cz>2015-03-24 16:34:41 +0100
committerJan Čermák <jan.cermak@nic.cz>2015-03-24 16:46:00 +0100
commit34b21dc910ca6519904a62ede9e78fa9da964f17 (patch)
treef1f31fe762a00dc54ced80787b7747ef149ef231 /lang/luasocket
parent9ca4f135e24ca2c92ef1fb089c76a4ae7057df63 (diff)
luasocket: add socket.unix module
Previous build was missing module socket.unix that is required for interaction with Unix domain sockets and is distributed in a separate shared library. This commit adds the file to the created package. Signed-off-by: Jan Čermák <jan.cermak@nic.cz>
Diffstat (limited to 'lang/luasocket')
-rw-r--r--lang/luasocket/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/luasocket/Makefile b/lang/luasocket/Makefile
index ceb707729..5e7c98300 100644
--- a/lang/luasocket/Makefile
+++ b/lang/luasocket/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=luasocket
PKG_SOURCE_VERSION:=6d5e40c324c84d9c1453ae88e0ad5bdd0a631448
PKG_VERSION:=3.0-rc1-20130909
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://github.com/diegonehab/luasocket.git
@@ -56,6 +56,7 @@ define Package/luasocket/install
ln -sf ../mime.so.1.0.3 $(1)/usr/lib/lua/mime/core.so
$(INSTALL_DIR) $(1)/usr/lib/lua/socket
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/{ftp,http,smtp,tp,url,headers}.lua $(1)/usr/lib/lua/socket
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/unix.so $(1)/usr/lib/lua/socket
ln -sf ../socket.so.3.0-rc1 $(1)/usr/lib/lua/socket/core.so
endef