aboutsummaryrefslogtreecommitdiff
path: root/lang/luasec
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-04-03 14:43:10 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2019-04-03 15:10:10 -0300
commite3f1532297bdc0fb1fb9bacd1a51405753d332f9 (patch)
treedff5921a27c570b0f523a9b452cb8253dcb70ffc /lang/luasec
parentc3c5b2f35531bf029847ca9d92c85a58a4a78672 (diff)
luasec: use gcc to link instead of ld
Linking with ld is not portable and was causing problems for some targets, e.g. i386_pentium4: i486-openwrt-linux-musl-ld: x509.o: in function `push_asn1_objname': x509.c:(.text+0x61): undefined reference to `__stack_chk_fail_local' ... Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'lang/luasec')
-rw-r--r--lang/luasec/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/luasec/Makefile b/lang/luasec/Makefile
index 29c120e1a..79120bbc4 100644
--- a/lang/luasec/Makefile
+++ b/lang/luasec/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=luasec
PKG_VERSION:=0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/brunoos/luasec/tar.gz/luasec-$(PKG_VERSION)?
@@ -45,6 +45,7 @@ TARGET_CFLAGS += $(FPIC)
TARGET_LDFLAGS += $(FPIC)
MAKE_FLAGS += \
+ LD="$(TARGET_CC)" \
INCDIR="$(TARGET_CPPFLAGS) -I." \
LIBDIR="$(TARGET_LDFLAGS) -L./luasocket" \
LUACPATH="$(PKG_INSTALL_DIR)/usr/lib/lua" \