aboutsummaryrefslogtreecommitdiff
path: root/lang/luasec
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2016-09-16 14:04:52 -0400
committerW. Michael Petullo <mike@flyn.org>2016-09-16 14:04:52 -0400
commit4399f887de2397f9fd65f1dc467e885fe7dd623d (patch)
tree5921665c2ba192f89bd99becaa667454881381d5 /lang/luasec
parentfb2d0feb0b023f62fd34f79abcf39359530d8091 (diff)
luasec: remove obsolete patches
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'lang/luasec')
-rw-r--r--lang/luasec/patches/100-luasocket-Makefile.patch20
-rw-r--r--lang/luasec/patches/200-compression-method-fix.patch24
2 files changed, 0 insertions, 44 deletions
diff --git a/lang/luasec/patches/100-luasocket-Makefile.patch b/lang/luasec/patches/100-luasocket-Makefile.patch
deleted file mode 100644
index 24de7fc79..000000000
--- a/lang/luasec/patches/100-luasocket-Makefile.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- luasec-luasec-0.5-old/src/luasocket/Makefile 2014-01-29 21:43:33.000000000 +0100
-+++ luasec-luasec-0.5/src/luasocket/Makefile 2014-11-30 13:07:44.850051000 +0100
-@@ -6,7 +6,7 @@
-
- CC ?= cc
- CFLAGS += $(MYCFLAGS) -DLUASOCKET_DEBUG
--AR := ar rcu
-+AR ?= ar
- RANLIB ?= ranlib
-
- .PHONY: all clean
-@@ -14,7 +14,7 @@
- all: libluasocket.a
-
- libluasocket.a: $(OBJS)
-- $(AR) $@ $(OBJS)
-+ $(AR) rcu $@ $(OBJS)
- $(RANLIB) $@
-
- clean:
diff --git a/lang/luasec/patches/200-compression-method-fix.patch b/lang/luasec/patches/200-compression-method-fix.patch
deleted file mode 100644
index e249bfb75..000000000
--- a/lang/luasec/patches/200-compression-method-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/src/ssl.c
-+++ b/src/ssl.c
-@@ -401,17 +401,21 @@ static int meth_want(lua_State *L)
- */
- static int meth_compression(lua_State *L)
- {
-+#ifndef OPENSSL_NO_COMP
- const COMP_METHOD *comp;
-+#endif
- p_ssl ssl = (p_ssl)luaL_checkudata(L, 1, "SSL:Connection");
- if (ssl->state != LSEC_STATE_CONNECTED) {
- lua_pushnil(L);
- lua_pushstring(L, "closed");
- return 2;
- }
-+#ifndef OPENSSL_NO_COMP
- comp = SSL_get_current_compression(ssl->ssl);
- if (comp)
- lua_pushstring(L, SSL_COMP_get_name(comp));
- else
-+#endif
- lua_pushnil(L);
- return 1;
- }